Bug 228165 - multi-lib conflicts in heartbeat
multi-lib conflicts in heartbeat
Status: CLOSED DUPLICATE of bug 341511
Product: Fedora
Classification: Fedora
Component: heartbeat (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-10 18:07 EST by Michael Schwendt
Modified: 2008-12-02 00:57 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-02 00:57:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2007-02-10 18:07:56 EST
heartbeat - 2.0.8-1.fc7.x86_64
  Conflicts: 120
  File conflict in:
     /usr/bin/cl_status
     /usr/sbin/crm_mon
     /usr/sbin/attrd_updater
     /usr/sbin/cibadmin
     /usr/sbin/ccm_tool
     /usr/sbin/crm_sh
     /etc/ha.d/shellfuncs
     /etc/ha.d/resource.d/hto-mapfuncs
     /usr/sbin/crm_failcount
     /usr/sbin/crm_standby
     /usr/sbin/iso8601
     /usr/sbin/crm_diff
     /usr/sbin/crm_attribute
     /usr/sbin/crmadmin
     /etc/ha.d/rc.d/hb_takeover
     /usr/sbin/crm_resource
     /usr/sbin/crm_master
     /usr/bin/cl_respawn
     /usr/sbin/crm_uuid
     /usr/sbin/crm_verify
     /usr/lib/ocf/resource.d/heartbeat/Dummy
     /usr/lib/ocf/resource.d/heartbeat/Xinetd
     /usr/lib/ocf/resource.d/heartbeat/rsyncd
     /usr/lib/ocf/resource.d/heartbeat/LinuxSCSI
     /usr/lib/ocf/resource.d/heartbeat/pingd
     /usr/lib/ocf/resource.d/heartbeat/SysInfo
     /usr/lib/ocf/resource.d/heartbeat/WAS6
     /usr/lib/ocf/resource.d/heartbeat/ServeRAID
     /usr/lib/ocf/resource.d/heartbeat/oracle
     /usr/lib/ocf/resource.d/heartbeat/Stateful
     /usr/lib/ocf/resource.d/heartbeat/EvmsSCC
     /usr/lib/ocf/resource.d/heartbeat/SendArp
     /usr/lib/ocf/resource.d/heartbeat/portblock
     /usr/lib/ocf/resource.d/heartbeat/Raid1
     /usr/lib/ocf/resource.d/heartbeat/ICP
     /usr/lib/ocf/resource.d/heartbeat/WinPopup
     /usr/lib/ocf/resource.d/heartbeat/drbd
     /usr/lib/ocf/resource.d/heartbeat/AudibleAlarm
     /usr/lib/ocf/resource.d/heartbeat/IPsrcaddr
     /usr/lib/ocf/resource.d/heartbeat/SAPDatabase
     /usr/lib/ocf/resource.d/heartbeat/ManageRAID
     /usr/lib/ocf/resource.d/heartbeat/ManageVE
     /usr/lib/ocf/resource.d/heartbeat/WAS
     /usr/lib/ocf/resource.d/heartbeat/IPaddr2
     /usr/lib/ocf/resource.d/heartbeat/db2
     /usr/lib/ocf/resource.d/heartbeat/mysql
     /usr/lib/ocf/resource.d/heartbeat/VIPArip
     /usr/lib/ocf/resource.d/heartbeat/Filesystem
     /usr/lib/ocf/resource.d/heartbeat/MailTo
     /usr/lib/ocf/resource.d/heartbeat/pgsql
     /usr/lib/ocf/resource.d/heartbeat/Pure-FTPd
     /usr/lib/ocf/resource.d/heartbeat/Xen
     /usr/lib/ocf/resource.d/heartbeat/IPaddr
     /usr/lib/ocf/resource.d/heartbeat/ClusterMon
     /usr/lib/ocf/resource.d/heartbeat/IPv6addr
     /usr/lib/ocf/resource.d/heartbeat/apache
     /usr/lib/ocf/resource.d/heartbeat/LVM
     /usr/lib/ocf/resource.d/heartbeat/oralsnr
     /usr/lib/ocf/resource.d/heartbeat/SAPInstance
     /usr/lib/ocf/resource.d/heartbeat/Delay
  Packages with the same files:
     heartbeat - 2.0.8-1.fc7.i386
Comment 1 Kevin Fenzi 2007-02-26 13:39:31 EST
I'm taking over the heartbeat package, so re-assigning this to me to look at. 
Comment 2 Kevin Fenzi 2007-06-27 23:29:02 EDT
I've moved the ocf files and they should be fixed in 2.0.8-3.fc8. 
The /etc/ha.d files are going to be more difficult, as they have path's in them. 
I will talk with upstream about those. 

Comment 3 Bug Zapper 2008-04-03 15:05:12 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 4 Kevin Fenzi 2008-04-03 16:39:37 EDT
Sadly, there are still some multilib issues with heartbeat. 
I have fixed a bunch, but there are still more to sort out. 

Comment 5 Bug Zapper 2008-05-13 22:36:17 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Kevin Fenzi 2008-12-02 00:57:52 EST
I am going to close this in favor of bug 341511.
There are still issues, and I am working with upstream to try and get them fixed. 

Feel free to add additional info or assistance over on that bug. 

Thanks for filing this.

*** This bug has been marked as a duplicate of bug 341511 ***

Note You need to log in before you can comment on or make changes to this bug.