Bug 228327 - crash opening document (on Thinkpad T43 with ATI video)
crash opening document (on Thinkpad T43 with ATI video)
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-12 12:46 EST by Ed Price
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-13 18:13:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed Price 2007-02-12 12:46:52 EST
Description of problem:

Trying to open this file:

http://people.redhat.com/berrange/summit-2006/Summit-2006-Daniel-P-Berrange.sxi

resulted in openoffice crash:

(I)    x.org loaded video driver of...
(II) Loading /usr/lib/xorg/modules/drivers/radeon_drv.so
(II) Loading /usr/lib/xorg/modules/drivers/ati_drv.so
(II) Reloading /usr/lib/xorg/modules/drivers/radeon_drv.so
(III)  Desktop is: GNOME
(IV)   libgcj version is: libgcj-4.1.1-51.fc6-i386
(V)    kernel is: Linux 2.6.19-1.2895.fc6 #1 SMP Wed Jan 10 18:32:37
EST 2007 i686 i686 i386
(VI)   OpenOffice.org core rpm version is: openoffice.org-core-2.0.4-5.5.10-i386
(VII)  depth of root window:    24 planes
(VIII) accessibility is: false
(VIV)  fedora release is: Fedora Core release 6 (Zod)
...start sestatus details ...
SELinux status:                 disabled
...end sestatus details ...
...start stackreport details ...
0x51eff28: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x22f28
0x51f0bbb: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x23bbb
0x743420:  + 0x420 (__kernel_sigreturn + 0x0)
0x51e74b4: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 +
0x1a4b4 (osl_getModuleURLFromAddress + 0xa4)
0x51e74f4: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 +
0x1a4f4 (osl_getModuleURLFromFunctionAddress + 0x24)
0x675933d: /usr/lib/openoffice.org2.0/program/libsfx680li.so +
0x35b33d (SystemShell::get_absolute_library_url(rtl::OUString const&)
+ 0x3d)
0x675941f: /usr/lib/openoffice.org2.0/program/libsfx680li.so +
0x35b41f (SystemShell::AddToRecentDocumentList(rtl::OUString const&,
rtl::OUString const&) + 0x2f)
0x659c1b9: /usr/lib/openoffice.org2.0/program/libsfx680li.so +
0x19e1b9 (SfxObjectShell::DoLoad(SfxMedium*) + 0x12d9)
0x65ff293: /usr/lib/openoffice.org2.0/program/libsfx680li.so +
0x201293
(SfxBaseModel::load(com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue>
const&) + 0x323)
0x663559f: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x23759f
0x7d6e646: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0x1a1646
0x7d6ee2a: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0x1a1e2a
0x7d6f345: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0x1a2345
0x7c13c53: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0x46c53
0x6fb8fcf: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x3dfcf
(desktop::DispatchWatcher::executeDispatchRequests(_STL::vector<desktop::DispatchWatcher::DispatchRequest,
_STL::allocator<desktop::DispatchWatcher::DispatchRequest> > const&) +
0x18cf)
0x6fab891: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x30891
(desktop::OfficeIPCThread::ExecuteCmdLineRequests(desktop::ProcessDocumentsRequest&)
+ 0x151)
0x6faba02: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x30a02
(desktop::ProcessEventsClass_Impl::ProcessDocumentsEvent(desktop::ProcessEventsClass_Impl*,
void*) + 0x22)
0x620ede6: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x281de6
0x8a6381: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so +
0x50381 (SalDisplay::DispatchInternalEvent() + 0xb1)
0x217d06: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0xfd06
0x217d41: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0xfd41
0x718d6e1: /lib/libglib-2.0.so.0 + 0x296e1
0x718f442: /lib/libglib-2.0.so.0 + 0x2b442 (g_main_context_dispatch + 0x182)
0x719241f: /lib/libglib-2.0.so.0 + 0x2e41f
0x7192985: /lib/libglib-2.0.so.0 + 0x2e985 (g_main_context_iteration + 0x65)
0x219cc1: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x11cc1
0x8a78a7: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so +
0x518a7 (X11SalInstance::Yield(bool, bool) + 0x37)
0x6022618: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x95618
(Application::Yield(bool) + 0x68)
0x60226ec: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x956ec
(Application::Execute() + 0x3c)
0x6fa1359: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x26359
(desktop::Desktop::Main() + 0x1779)
0x60281bc: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x9b1bc
0x60282c5: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x9b2c5
(SVMain() + 0x35)
0x6f92a69: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x17a69
(sal_main + 0x59)
0x6f92af4: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x17af4
(main + 0x44)
0xb02f2c: /lib/libc.so.6 + 0x15f2c (__libc_start_main + 0xdc)
0x8048481: /usr/lib/openoffice.org2.0/program/soffice.bin + 0x481
...end stackreport details ...
...start sample ldd details ...
       linux-gate.so.1 =>  (0x0095b000)
       libuno_sal.so.3 => /usr/lib/openoffice.org2.0/program/libuno_sal.so.3
(0x00d74000)
       libuno_salhelpergcc3.so.3 =>
/usr/lib/openoffice.org2.0/program/libuno_salhelpergcc3.so.3
(0x00a9c000)
       libstore.so.3 => /usr/lib/openoffice.org2.0/program/libstore.so.3
(0x00420000)
       libdl.so.2 => /lib/libdl.so.2 (0x00110000)
       libpthread.so.0 => /lib/libpthread.so.0 (0x00fb5000)
       libstlport_gcc.so =>
/usr/lib/openoffice.org2.0/program/libstlport_gcc.so (0x0014b000)
       libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00212000)
       libm.so.6 => /lib/libm.so.6 (0x00c7c000)
       libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x007c2000)
       libc.so.6 => /lib/libc.so.6 (0x00438000)
       libcrypt.so.1 => /lib/libcrypt.so.1 (0x00114000)
       /lib/ld-linux.so.2 (0x80000000)
...end sample ldd details ...

Version-Release number of selected component (if applicable):
(latest updates)

How reproducible:
always

Steps to Reproduce:
1. visit http://people.redhat.com/berrange/summit-2006/ and click on the
OpenOffice slides link (URL as above)
2.
3.
  
Actual results:
crash

Expected results:
see document in openoffice

Additional info:
As a workaround, I ssh'ed to localhost as another user and opened the document.
Since the other user isn't allowed to do "direct rendering" or whatever
(according to msgs printed by openoffice when running it from cmdline), it
appears this avoids the video driver issue.

Thinkpad T43.  lspci:

00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express
Processor to DRAM Controller (rev 03)
00:01.0 PCI bridge: Intel Corporation Mobile 915GM/PM Express PCI Express Root
Port (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI
Express Port 1 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI
Express Port 3 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #3 (rev 03)
00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #4 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB2 EHCI Controller (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev d3)
00:1e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW
(ICH6 Family) AC'97 Audio Controller (rev 03)
00:1e.3 Modem: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Modem
Controller (rev 03)
00:1f.0 ISA bridge: Intel Corporation 82801FBM (ICH6M) LPC Interface Bridge (rev 03)
00:1f.2 IDE interface: Intel Corporation 82801FBM (ICH6M) SATA Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus
Controller (rev 03)
01:00.0 VGA compatible controller: ATI Technologies Inc M22 [Radeon Mobility M300]
02:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5751M Gigabit
Ethernet PCI Express (rev 11)
04:00.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev 8d)
04:02.0 Network controller: Intel Corporation PRO/Wireless 2915ABG Network
Connection (rev 05)
Comment 1 Caolan McNamara 2007-02-13 03:57:56 EST
Hmm, no crash for me, and from the stack I'd not expect the video driver to
cause this. Could you attach the ~/.recentlyused file from the account on the
machine where OOo crashed, perhaps OOo got confused trying to update that file.
Comment 2 Ed Price 2007-02-13 18:13:43 EST
I tried again and it said something about trying to recover a different file.
When I said "cancel" on that, it then opened the document just fine.
So, I was really jumping to conclusions about what was going on, sorry!!!
Now I can't reproduce the problem.
I'll close this as ... no INVALID, so WORKSFORME I guess.
THANKS for your response and sorry again for rushing that report.

Note You need to log in before you can comment on or make changes to this bug.