Bug 228329 - ed 0.3 causes rpmbuild to fail
ed 0.3 causes rpmbuild to fail
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: ed (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-12 13:00 EST by Brian Collins
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-07 07:49:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Collins 2007-02-12 13:00:09 EST
Description of problem: rebuilding stock Postfix from source, the ed script
which modifies 'postfix-files' fails, causing rpmbuild to fail.  This is worked
around by installing older ed-0.2.

Version-Release number of selected component (if applicable): ed-0.3


How reproducible: easily

Steps to Reproduce:
1. download Postfix SRPM from any mirror site
2. have ed-0.3 installed
3. run 'rpmbuild --rebuild' on the Postfix SRPM package
  
Actual results:  During the RPM build, the following output occurs:
+ ed /var/tmp/postfix-buildroot/etc/postfix/postfix-files
17479
?
+ exit 1
error: Bad exit status from /var/tmp/rpm-tmp.62236 (%install)

Expected results:  An RPM build with an exit status of 0.


Additional info:  This may happen in other package builds as well, and in many
ed scripts.  This is the first I have run across it.
Comment 1 Karsten Hopp 2007-02-14 09:36:41 EST
I've reported this upstream, testcase:
cat >> testfile << EOF
This is a test
EOF


with ed-0.2:
>ed testfile << EOF
> %s/test/dummy/
> w
> q
> EOF
40
42
>cat testfile
this is a failed test

with ed-0.3/0.4:
>ed testfile << EOF
> %s/test/dummy/
> w
> q
> EOF
40
?
>cat testfile
This is a test 
Comment 2 Karsten Hopp 2007-03-07 07:49:40 EST
the upstream maintainer told me that '%' as a range is no longer valid range.
I think I'll revert to an older ed-version as the new one doesn't really fix
anything,it just causes problems with oder scripts. For now you can use '1,$'
instead of '%'.
See
http://lists.gnu.org/archive/html/bug-ed/2007-03/msg00000.html
Comment 3 Karsten Hopp 2007-03-14 09:31:49 EDT
can you please try ed-0.5 from rawhide ? The maintainer added support for '%'
ranges after he got some pressure from several sides.
Comment 4 Brian Collins 2007-03-18 22:51:03 EDT
Tried ed-0.5 from rawhide and it worked.

Note You need to log in before you can comment on or make changes to this bug.