Bug 228346 - multi-lib conflicts
multi-lib conflicts
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: WindowMaker (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE7Target
  Show dependency treegraph
 
Reported: 2007-02-12 14:44 EST by Michael Schwendt
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-25 17:14:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
- install WPrefs data files in %_datadir, and WPrefs in %_bindir (1.81 KB, patch)
2007-02-14 05:36 EST, Patrice Dumas
no flags Details | Diff

  None (edit)
Description Michael Schwendt 2007-02-12 14:44:25 EST
WindowMaker - 0.92.0-10.fc7.x86_64
  Conflicts: 4
  File conflict in:
     /etc/WindowMaker/WMState
  Packages with the same files:
     WindowMaker - 0.92.0-10.fc7.i386
Comment 1 Patrice Dumas 2007-02-14 05:36:08 EST
Created attachment 148045 [details]
- install WPrefs data files in %_datadir, and WPrefs in %_bindir

Beside (hopefully) fixing the multilib issue, I believe these are saner 
install locations. I have built and installed, but not tested.
Comment 2 Michael Schwendt 2007-02-14 06:07:50 EST
The real issue here is a key question:

Do we really need WindowMaker.i386 in the x86_64 repo just because
the dependency path of a WindowMaker -devel package leads to this
package? That means, is it possible to split off a package, on which
the -devel package can depend on without requiring the main package?

Further, files in /etc are no hard conflicts if they are marked
%config. They just lead to ugly and unnecessary .rpmsave creation.
Comment 3 Patrice Dumas 2007-02-14 06:45:27 EST
I agree that it would be even better to split a -libs 
subpackage but the patch I propose should be applied anyway
to correct installation locations.

It seems like a -libs package existed in the past and that it 
was removed.

WindowMaker packaging could be ameliorated a lot, in fact.
I think that something like a re-review could help.
Comment 4 Andreas Bierfert 2007-02-14 16:56:33 EST
Thanks for the patch. Seems better to me as well to put WPrefs stuff in the
'right' locations. The multi lib stuff is low priority so I will look at
splitting of a -libs package sometime next week when I will have more time for this.

Patrice if you dislike stuff about the wmaker package just drop me a mail and we
can discuss stuff.

Note You need to log in before you can comment on or make changes to this bug.