Bug 228363 - multi-lib conflicts
Summary: multi-lib conflicts
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gstreamer-python   
(Show other bugs)
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Denis Leroy
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FE7Target
TreeView+ depends on / blocked
 
Reported: 2007-02-12 20:04 UTC by Michael Schwendt
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-27 16:03:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael Schwendt 2007-02-12 20:04:10 UTC
gstreamer-python - 0.10.6-1.fc7.x86_64
  Conflicts: 28
  File conflict in:
     /usr/share/gst-python/0.10/examples/play.pyc
     /usr/share/gst-python/0.10/examples/play.pyo
     /usr/share/gst-python/0.10/examples/vumeter.pyo
     /usr/share/gst-python/0.10/examples/vumeter.pyc
     /usr/share/gst-python/0.10/examples/gstfile.pyo
     /usr/share/gst-python/0.10/examples/gstfile.pyc
     /usr/share/gst-python/0.10/examples/sinkelement.pyc
     /usr/share/gst-python/0.10/examples/audio-controller.pyc
     /usr/share/gst-python/0.10/examples/audio-controller.pyo
     /usr/share/gst-python/0.10/examples/sinkelement.pyo
     /usr/share/gst-python/0.10/examples/decodebin.pyc
     /usr/share/gst-python/0.10/examples/decodebin.pyo
     /usr/share/gst-python/0.10/examples/cp.pyo
     /usr/share/gst-python/0.10/examples/debugslider.pyc
     /usr/share/gst-python/0.10/examples/debugslider.pyo
     /usr/share/gst-python/0.10/examples/bps.pyc
     /usr/share/gst-python/0.10/examples/bps.pyo
     /usr/share/gst-python/0.10/examples/f2f.pyo
     /usr/share/gst-python/0.10/examples/f2f.pyc
     /usr/share/gst-python/0.10/examples/filesrc.pyc
     /usr/share/gst-python/0.10/examples/filesrc.pyo
     /usr/share/gst-python/0.10/examples/cp.pyc
     /usr/share/gst-python/0.10/examples/remuxer.pyo
     /usr/share/gst-python/0.10/examples/remuxer.pyc
     /usr/share/gst-python/0.10/examples/audioconcat.pyo
     /usr/share/gst-python/0.10/examples/audioconcat.pyc
     /usr/share/gst-python/0.10/examples/fvumeter.pyo
     /usr/share/gst-python/0.10/examples/fvumeter.pyc
  Packages with the same files:
     gstreamer-python - 0.10.6-1.fc7.i386

Comment 1 Denis Leroy 2007-02-20 09:41:06 UTC
The conflicts are caused by the compiled examples. Interestingly, the examples
are compiled by rpmbuild itself, not by the package autotool setup. Is there a
way to prevent rpm from doing this ?

These files are actually packaged twice (also packaged by the %doc/examples/*.py
line). My proposed solution/workaround is to remove
/usr/share/gst-python/0.10/examples/ altogether, and ship the examples under
/usr/share/doc/gstreamer-python-0.10.7/ only. How does that sound ?


Comment 2 Denis Leroy 2007-02-27 16:03:16 UTC
Should be fixed now with 0.10.7



Note You need to log in before you can comment on or make changes to this bug.