Bug 228390 - multi-lib conflicts
multi-lib conflicts
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: uudeview (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Reber
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE7Target
  Show dependency treegraph
 
Reported: 2007-02-12 15:34 EST by Michael Schwendt
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-14 08:37:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2007-02-12 15:34:34 EST
uulib - 0.5.20-10.x86_64
  Conflicts: 1
  File conflict in:
     /usr/share/doc/uulib-0.5.20/library.pdf
  Packages with the same files:
     uulib - 0.5.20-10.i386
Comment 1 Adrian Reber 2007-02-12 15:49:56 EST
any hint how this can be fixed? because I have no idea...
Comment 2 Michael Schwendt 2007-02-12 16:44:25 EST
I have ideas.

Option 1) Kill the main package and include all files in "uulib-devel",
because this package contains only a static library with headers and
is not needed at run-time at all. Hence it is not a real multi-lib
package anyway, but a devel-only package. There is no requirement for
-devel packages to be free of conflicts in multi-lib installations
(headers may include arch-dependent definitions, for example).

Option 2) An ugly cheat: /usr/share/doc/uulib-0.5.20/%{arch}/library.pdf
Comment 3 Adrian Reber 2007-02-14 08:37:29 EST
Thanks! I have taken option 1.

Note You need to log in before you can comment on or make changes to this bug.