Bug 228414 - (r400-dri-startup) X hangs at startup with Radeon X800 GTO (PCIe) with DRI
X hangs at startup with Radeon X800 GTO (PCIe) with DRI
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Airlie
: Desktop
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-12 18:36 EST by Nils Philippsen
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-06 02:11:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/X11/xorg.conf of the machine in question (1.17 KB, text/plain)
2007-03-17 07:29 EDT, Nils Philippsen
no flags Details
Xorg.0.log with xorg.conf (74.09 KB, text/plain)
2007-03-17 07:30 EDT, Nils Philippsen
no flags Details
Xorg.0.log without xorg.conf (74.26 KB, text/plain)
2007-03-17 07:30 EDT, Nils Philippsen
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 9957 None None None Never

  None (edit)
Description Nils Philippsen 2007-02-12 18:36:59 EST
When starting X (with DRI enabled), the screen just goes blank and the keyboard
is dead. Xorg consumes 100% CPU and can't be killed... well it doesn't really
go away, just the terminal shows it is killed, but there is an Xorg process
with the same pid hogging the CPU. When run trough strace (before killing), it
just endlessly does:

ioctl(9, 0x6444, 0)                     = -1 EBUSY (Device or resource busy)

FD #9 is /dev/dri/card0 (as is FD #10 FWIW). My X version is:

root@wombat:~> Xorg -version

X Window System Version 7.1.1
Release Date: 12 May 2006
X Protocol Version 11, Revision 0, Release 7.1.1
Build Operating System: Linux 2.6.9-34.ELsmp x86_64 Red Hat, Inc.
Current Operating System: Linux wombat 2.6.18-1.2869.fc6 #1 SMP Wed Dec 20
14:51:34 EST 2006 x86_64
Build Date: 29 January 2007
Build ID: xorg-x11-server 1.1.1-47.5.fc6 
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Module Loader present
root@wombat:~> rpm -q xorg-x11-server-Xorg xorg-x11-drv-ati
xorg-x11-server-Xorg-1.1.1-47.5.fc6
xorg-x11-drv-ati-6.6.3-1.fc6

I found some oddities in the log file, namely that a) the driver was somehow
confused by the cards secondary bus ID, b) it didn't recognize the Radeon X800
GTO as such, but as an X850 PRO and c) somehow used only 128MB of the 256MB
card:

  (II) Primary Device is: PCI 07:00:0
  (--) Assigning device section with no busID to primary device
  (WW) RADEON: No matching Device section for instance (BusID PCI:7:0:1) found
  (--) Chipset ATI Radeon X850 PRO (R480) (PCIE) found
  (II) resource ranges after xf86ClaimFixedResources() call:

  [...]

  (II) RADEON(0): Page flipping disabled
  (II) RADEON(0): Will try to use DMA for Xv image transfers
  (II) RADEON(0): Generation 2 PCI interface, using max accessible memory
  (II) RADEON(0): Detected total video RAM=262144K, accessible=131072K (PCI
BAR=131072K)
  (--) RADEON(0): Mapped VideoRAM: 131072 kByte (256 bit DDR SDRAM)
  (II) RADEON(0): Color tiling enabled by default

The output of lspci -v also shows that only 128MB are mapped.

I could get X to work when I disabled DRI (I used "install radeon /bin/false"
in /etc/modprobe.conf to do that). I've attached xorg.conf, Xorg.0.log, strace
output (shortened) and lspci output to the upstream bugreport:

https://bugs.freedesktop.org/show_bug.cgi?id=9957
Comment 1 Matěj Cepl 2007-03-02 13:07:33 EST
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Nils Philippsen 2007-03-17 07:29:04 EDT
Created attachment 150304 [details]
/etc/X11/xorg.conf of the machine in question
Comment 3 Nils Philippsen 2007-03-17 07:30:16 EDT
Created attachment 150305 [details]
Xorg.0.log with xorg.conf
Comment 4 Nils Philippsen 2007-03-17 07:30:52 EDT
Created attachment 150306 [details]
Xorg.0.log without xorg.conf
Comment 5 Nils Philippsen 2007-03-17 07:34:02 EDT
Matej, running without xorg.conf didn't change things. Note that you could have
found xorg.conf and the log on the upstream bugzilla as well ;-). There's also
strace output that might be of use.
Comment 6 Nils Philippsen 2007-03-30 04:12:42 EDT
Just FYI, I tried (32bit) Knoppix 5.2 and found the same problem, i.e. this is
not a 32bit vs. 64bit thing.
Comment 7 Nils Philippsen 2007-04-27 16:16:24 EDT
Just FYI (again ;-)), I tried F7 test4 Live (64bit) and the problem was still there.
Comment 8 Nils Philippsen 2007-08-30 18:31:31 EDT
Just reproduced the problem with:

kernel-2.6.22.4-65.fc7
xorg-x11-drv-ati-6.6.3-4.fc7

Is there anything else I should try (Rawhide?) -- I'm eager to work on this as
I've been suffering from a lack of 3D (gaming, caring for my 3D packages) for a
while ;-). 
Comment 9 Dave Airlie 2007-08-30 18:55:10 EDT
trying the rawhide ati driver might very useful as it has a major rework of the
ati radeon driver.... I'm not sure if you need to pull in the xserver and mesa
packages as well for it to work...
Comment 10 Nils Philippsen 2007-08-31 03:19:48 EDT
RPM requirements are basically the same. I'll give it a try.
Comment 11 Nils Philippsen 2007-08-31 03:48:47 EDT
Without DRI, it gave me a 800x600 resolution. But that may as well be a part of
the new XRandR-enabled "users have to be explicit that they don't need
prescription glasses" world order of things ;-). Will that be fixed in F8 or can
it be easily worked around?

With DRI (i.e. the Radeon kernel driver loaded), it gave me the same 800x600
resolution with a moving mouse pointer and the contents of whatever was in the
framebuffer. Nothing else working, I tried to one time kill it with
Ctrl-Alt-BackSpc or to switch consoles with Ctrl-Alt-F1, both of which hung X
completely.

Do you think it should make a difference with F8/Rawhide. I've got a free disk
ATM so I could install it there (if it's installable at all right now?).
Comment 12 Nils Philippsen 2007-09-03 03:50:21 EDT
I've installed Rawhide now (what a mess ATM ;-) and found that with the DRM
module loaded, it's much similar to comment #11: It gives a working mouse
cursor, but the FB contents are "what's there", in my case I could (with a a bit
imagination) see parts of my usual desktop background, but heavily distorted --
it still only does 800x600 no matter what I try to fiddle in xorg.conf while my
desktop is 1400x1050.

I've dug a bit into that second problem and found from Xorg.0.log that it seems
to think that a TV is my main display or something similarly bogus. Is that an
already known problem or shall I open a new bug for it?
Comment 13 Nils Philippsen 2007-09-03 03:53:43 EDT
Forgot the package versions in comment #12:

xorg-x11-drv-ati-6.7.192-1.fc8
xorg-x11-server-Xorg-1.3.0.0-22.fc8
kernel-2.6.23-0.149.rc4.fc8
Comment 14 Dave Airlie 2007-09-25 19:16:40 EDT
Is there any luck with the latest rawhide driver? upstream has been fixing ATI
bugs in this area at an extreme rate...
Comment 15 Nils Philippsen 2007-09-27 03:53:06 EDT
I'll check this soonish, when I don't need the machine for "real work" ;-).
Comment 16 Nils Philippsen 2007-09-28 04:32:24 EDT
Doesn't work (black screen, hung, SysRq works):

xorg-x11-drv-ati-6.7.194-1.fc8
kernel-2.6.23-0.204.rc8.fc8
Comment 17 Nils Philippsen 2007-11-05 09:03:53 EST
Dave, according to upstream (http://bugs.freedesktop.org/show_bug.cgi?id=9957
comments 40-42), you seem to have fixed this in current drm-git (which
apparently needs mesa-git, xserver-git to function well). It would be nice if
you could backport these changes. F8 would be sufficient for me, I'll upgrade my
machine shortly.
Comment 18 Dave Airlie 2007-11-05 15:55:04 EST
I'll hopefully get the patch into the Fedora kernel so it'll be there early in
F8 updates and I'll stick it in F7 kernel as well for good measure...

Comment 19 Nils Philippsen 2007-11-05 17:03:45 EST
Is it only the kernel that needs fixing? The comments upstream about AIGLX seem
to suggest otherwise.
Comment 20 Dave Airlie 2007-11-06 02:11:45 EST
http://koji.fedoraproject.org/koji/taskinfo?taskID=227206

contains some kernel packages for F8 with the fix in them.. no other fix is
necessary for Fedora. I've checked the fix in to the kernel tree for F-7 and F-8
so the kernel releases on those should have it in them soon.
Comment 21 Nils Philippsen 2007-11-08 05:26:02 EST
kernel-2.6.23.1-45.fc8 works for me, thanks a lot!

Note You need to log in before you can comment on or make changes to this bug.