Bug 228422 - LSPP: cleanup xfrm_audit_log interface
LSPP: cleanup xfrm_audit_log interface
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Eric Paris
Brian Brock
: OtherQA
Depends On:
Blocks: 234654 RHEL5LSPPCertTracker
  Show dependency treegraph
 
Reported: 2007-02-12 19:36 EST by Joy Latten
Modified: 2010-10-22 08:58 EDT (History)
6 users (show)

See Also:
Fixed In Version: RHBA-2007-0959
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 14:40:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
LSPP.65 kernel patch for this issue. (2.38 KB, patch)
2007-02-19 12:24 EST, Eric Paris
no flags Details | Diff

  None (edit)
Description Joy Latten 2007-02-12 19:36:58 EST
Description of problem:

xfrm_audit_log()is not called correctly and BUG() needs to be added to ensure
some arguments are valid.

When called in xfrm_get_policy() causes a kernel crash. 

A patch has been posted on netdev mailing list and is currently undergoing a
review there.

This problem exists in lspp kernel and upstream kernel.
Comment 1 Eric Paris 2007-02-16 13:57:01 EST
Notes to self:

http://marc.theaimsgroup.com/?l=linux-netdev&m=117132072022494&w=2

Going to need to revert patch # 21202 
Name: linux-2.6-xfrm-audit-correct-xfrm-auditing-panic.patch

To put this in.
Comment 2 Eric Paris 2007-02-19 12:24:31 EST
Created attachment 148347 [details]
LSPP.65 kernel patch for this issue.

LSPP.65 kernel reveted the last fix for this problem and this patch should
implement the upstream fix.  Since the original problem is a panic we probably
need to be sure to solicit the upstream testers who found the problem to
specifically test with this patch.
Comment 3 Eric Paris 2007-03-06 16:32:03 EST
I need to post this for a RHEL5 update.  It is upstream and has been verified as
still working in the LSPP kernels.
Comment 4 Joy Latten 2007-03-16 17:41:54 EDT
Tested xfrm_get_policy in LSPP kernel using a test program and appears ok.
Comment 6 RHEL Product and Program Management 2007-03-28 14:42:11 EDT
This request was evaluated by Red Hat Kernel Team for inclusion in a Red
Hat Enterprise Linux maintenance release, and has moved to bugzilla 
status POST.
Comment 7 Don Zickus 2007-04-23 17:51:22 EDT
in 2.6.18-16.el5
Comment 9 John Poelstra 2007-08-27 14:38:19 EDT
A fix for this issue should have been included in the packages contained in the
RHEL5.1-Snapshot3 on partners.redhat.com.  

Requested action: Please verify that your issue is fixed as soon as possible to
ensure that it is included in this update release.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to FAILS_QA.

More assistance: If you cannot access bugzilla, please reply with a message to
Issue Tracker and I will change the status for you.  If you need assistance
accessing ftp://partners.redhat.com, please contact your Partner Manager.
Comment 10 Joy Latten 2007-08-28 14:14:24 EDT
Verified that this is fixed.
Comment 12 errata-xmlrpc 2007-11-07 14:40:10 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0959.html

Note You need to log in before you can comment on or make changes to this bug.