Bug 22845 - aspell leaves cores in my home directory plenty
aspell leaves cores in my home directory plenty
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: aspell (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-26 11:43 EST by Gregory Leblanc
Modified: 2007-04-18 12:30 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-28 13:28:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gregory Leblanc 2000-12-26 11:43:52 EST
I've re-compiled aspell locally with brp-strip and brp-strip-comments disabled, so that I could get a proper backtrace.  Here's what I got:
[gleblanc@peecee gleblanc]$ gdb -c core `which aspell`
GNU gdb 5.0
Copyright 2000 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux"...
Core was generated by `aspell -a'.
Program terminated with signal 3, Quit.
Reading symbols from /usr/lib/libaspell.so.8...done.
Loaded symbols for /usr/lib/libaspell.so.8
Reading symbols from /usr/lib/libpspell.so.2...done.
Loaded symbols for /usr/lib/libpspell.so.2
Reading symbols from /usr/lib/libpspell-impl.so.3...done.
Loaded symbols for /usr/lib/libpspell-impl.so.3
Reading symbols from /usr/lib/libstdc++-libc6.2-2.so.3...done.
Loaded symbols for /usr/lib/libstdc++-libc6.2-2.so.3
Reading symbols from /lib/libm.so.6...done.
Loaded symbols for /lib/libm.so.6
Reading symbols from /lib/libc.so.6...done.
Loaded symbols for /lib/libc.so.6
Reading symbols from /usr/lib/libltdl.so.0...done.
Loaded symbols for /usr/lib/libltdl.so.0
Reading symbols from /usr/lib/libpspell-modules.so.1...done.
Loaded symbols for /usr/lib/libpspell-modules.so.1
Reading symbols from /lib/ld-linux.so.2...done.
Loaded symbols for /lib/ld-linux.so.2
Reading symbols from /lib/libdl.so.2...done.
Loaded symbols for /lib/libdl.so.2
#0  0x400be91c in __do_global_ctors_aux () from /usr/lib/libaspell.so.8
(gdb) bt
#0  0x400be91c in __do_global_ctors_aux () from /usr/lib/libaspell.so.8
#1  0x4006bc32 in _init () from /usr/lib/libaspell.so.8
#2  0x4000d36d in _dl_init (main_map=0x40016038, argc=2, argv=0xbffff5c4, env=0xbffff5d0) at dl-init.c:111
(gdb) 

Any ideas on what's causing this, or what I can do to further track down the problem?
Comment 1 Trond Eivind Glomsrxd 2000-12-26 18:03:32 EST
If you could reproduce it exactly (with a specific file, a specific dictionary 
and with an exact set of commands), that would bevery helpful/essential.
Comment 2 Gregory Leblanc 2001-01-13 03:10:15 EST
As I'm never running aspell by hand, it's hard to say what is causing this.  However, while my system is running, I've got an aspell process which is associated with gnomeicu.  I'll ask around and see if anybody has suggestions on how to track down exactly what that's doing, and would appreciate any hints that you might have.
Comment 3 Trond Eivind Glomsrxd 2001-01-20 17:10:38 EST
Did you find anything?

(if you want to find out what options are used with aspell when not running it
directly, you can try "ps -xwww"
Comment 4 Craig Kelley 2001-01-22 16:45:35 EST
I can verify this bug:

# aspell --mode=email check ./configure 
Segmentation fault (core dumped)

The file above is from my hylafax configuration, and you can
download it via http://inconnu.isu.edu/~ink/configure

It also coredumps on me within pine regularly.  This is on a RedHat 6.2 box
for which I upgraded to the latest pine (as per errata instructions), and then
had to manually compile aspell and aspell from the SRPMS in RedHat 7.  I had
to do this because the RPM for Pine 4.30 supplied broke ispell, and my users
howled loudly.

If any other information is needed, please let me know.
Comment 5 Trond Eivind Glomsrxd 2001-01-22 16:53:46 EST
That works just fine for me - no coredumps.

[teg@halden teg]$ aspell --mode=email check ./configure
#
$Id: configure,v 1.19 1999/07/01 10:30:54 *robert* Exp $
1) Robert                               5) Robt
2) Roberta                              6) robed
3) Roberto                              7) robot
4) Roberts
i) Ignore                               I) Ignore all
r) Replace                              R) Replace all
a) Add                                  x) Exit
? 1
#
$Id: configure,v 1.19 1999/07/01 10:30:54 Robert *Exp* $
1) Ex                                   3) ESP
2) Expo                                 4) Esp
i) Ignore                               I) Ignore all
r) Replace                              R) Replace all
a) Add                                  x) Exit
? I
# *HylaFAX* Facsimile Software
1) Halifax                              5) Halifax's
2) Colfax                               6) Helix
3) Filofax                              7) Haylofts
4) Half's
i) Ignore                               I) Ignore all
r) Replace                              R) Replace all
a) Add                                  x) Exit
? a
Comment 6 Craig Kelley 2001-01-22 17:01:04 EST
Strange.  It appears to be a problem with back-porting it to older
distributions.  Try to install pine-4.3.xxxx.rpm on a redhat 6.x machine
and (after spelling breaks) get it to work with aspell.  I don't know
if this bug should be NOTABUGged here, because we're talking about a package
in 7.x (and migrate this bug report over to pine-4.3.x for redhat < 7.x) or if
it should be fixed here.  Perhaps a pine maintainer should comment?  I know
pine-4.3.x can use the older ispell, but the package supplied by redhat
does not.


Comment 7 Trond Eivind Glomsrxd 2001-01-22 17:05:53 EST
To get ispell working with pine again, just comment the entry in /etc/pine.conf
specifying use of aspell... this shouldn't be there, and will be fixed in the
next errata (which I thought Mike had released, but apparently not)
Comment 8 Mike A. Harris 2001-01-28 13:28:50 EST
I have fixed it.  There are a couple other fixes for PINE I need to
integrate first before releasing errata for 7.0/6.2/5.2 though.

I expect to be releasing new PINE errata real soon now.
Comment 9 Trond Eivind Glomsrxd 2001-02-15 10:23:26 EST
Since the given testcase works just fine, I'm closing this.

Note You need to log in before you can comment on or make changes to this bug.