Bug 22846 - Error installing Redhat linux
Summary: Error installing Redhat linux
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-26 16:57 UTC by Need Real Name
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-27 16:49:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-12-26 16:57:29 UTC
While installing Redhat Linux 7.0 on my computer:

relevant specs:
HD: maxtor 30,7GB disk (ATA100) I have ATA100 disabled and it's now 
connected to my IDE controller.
Mobo: Asus A7V
Proc: AMD TB 850
Mouse: Logitec wheelmouse optical

 While installing, i have no trouble, but Linux does not recognize my 
mouse (it's probing my usb ports, but can't find a mouse - got a timeout 
error for i guess 10-15 times, it does not matter if i connect it to my 
usb port or to my ps/2 port. Text mode gives the same result.) Then, 
Redhat starts the installation and i can go on.

After setting up partitions, users and selecting boot partitions, it gives 
me this crashdump, and asks to report it. Here goes:

---------------------------------------------------------------------------

Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in 
run
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/textw/packages_text.py", 
line 33, in __call__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 539, in 
getCompsList
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/harddrive.py", line 43, 
in readComps
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 459, in 
__init__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 428, in 
readCompsFile
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 101, in 
__getitem__
KeyError: indexhtml

Local variables in innermost frame:
self: <comps.HeaderList instance at 824b938>
item: indexhtml

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iharddrive
HardDriveInstallMethod
p4
(dp5
S'fstype'
p6
S'vfat'
p7
sS'isMounted'
p8
I1
sS'fnames'
p9
(dp10

<failed>

---------------------------------------------------------------------------

I hope this is enough info, if not, ask for more, I'll be glad to help.

Comment 1 Need Real Name 2000-12-26 17:28:13 UTC
I just found out there was another bug report with the same prob. I guess i 
should download everything again.

Maybe you can tell me how I can check which of my files are different? some 
list to check how big all files should be or something like that? like the 
dos 'comp' command.

Comment 2 Need Real Name 2000-12-26 19:41:45 UTC
I manually checked all files and compared them to the ones on the ftp I 
downloaded them from - ALL 866 of those RPMS +some base - and it was excactly 
the same. what do i do?


Comment 3 Need Real Name 2000-12-26 20:42:48 UTC
I see I had compared this one with the wrong bug.. This bug is the same as in 
18019, but in that one, there is not yet a final solution to this problem. I 
will try the binary download first, but maybe someone here should check that 
bug, since no final solution has been found.

Comment 4 Need Real Name 2000-12-26 20:56:42 UTC
I tried and failed using the 'forced binary' transfer of indexhtml...

Comment 5 Need Real Name 2000-12-26 22:07:21 UTC
I don't know how, but everytime I download indexhtml, it gives me a file of 
17.031 bytes, while the server says it's 16.967 .. I think those other blokes 
are having the same prob, but didn't find out about the size diffs. Anyway, 
after tweaking my ftpclient for an hour or 2, I finally managed to download it 
as it should be. I'm gonna try it now...

NB: the binary/ascii mode gave no differences. With both modi I got a 17.031 
size file!!

Comment 6 Michael Fulbright 2000-12-27 16:49:45 UTC
I would recommend trying a different source for the file.

Comment 7 Need Real Name 2001-01-08 19:17:47 UTC
aaah i finally managed to get my inet back again (arggh windows.. and i didnt 
yet have the neccesary linux howto's, so i couldnt set it up..

anyway, after doing this I managed to install linux. maybe it is of some help 
to other people to know you can solve this. I agree it's not really a linux 
bug, but i see lots of people are having this problem.

thanks for your time.

SilentStorm


Note You need to log in before you can comment on or make changes to this bug.