Bug 228531 - [RHEL4] wacom: remove bogus le16_to_cpu() from usb_hid_config()
Summary: [RHEL4] wacom: remove bogus le16_to_cpu() from usb_hid_config()
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 4.4
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Aristeu Rozanski
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-13 16:58 UTC by Aristeu Rozanski
Modified: 2007-11-17 01:14 UTC (History)
3 users (show)

Fixed In Version: RHBA-2007-0304
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-08 04:51:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch (488 bytes, patch)
2007-02-13 16:58 UTC, Aristeu Rozanski
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0304 normal SHIPPED_LIVE Updated kernel packages available for Red Hat Enterprise Linux 4 Update 5 2007-04-28 18:58:50 UTC

Description Aristeu Rozanski 2007-02-13 16:58:35 UTC
In latest wacom driver update, a bogus conversion is done to get the vendor id of
new usb devices. This is wrong because it is already converted to CPU ordering.

Comment 1 Aristeu Rozanski 2007-02-13 16:58:35 UTC
Created attachment 148005 [details]
proposed patch

Comment 2 Aristeu Rozanski 2007-02-13 16:59:44 UTC
Patch tested on a little endian machine successfully.


Comment 4 RHEL Product and Program Management 2007-02-13 19:04:47 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 5 Jay Turner 2007-02-16 15:56:43 UTC
QE ack for RHEL4.5.

Comment 6 Jason Baron 2007-02-27 20:45:27 UTC
committed in stream U5 build 49. A test kernel with this patch is available from
http://people.redhat.com/~jbaron/rhel4/


Comment 8 Mike Gahagan 2007-03-29 20:26:42 UTC
Patch is in the -52 kernel.


Comment 10 Red Hat Bugzilla 2007-05-08 04:51:04 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0304.html


Note You need to log in before you can comment on or make changes to this bug.