Bug 228665 - Module bcm43xx crash kernel with mem >1G
Module bcm43xx crash kernel with mem >1G
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
ftp://lwfinger.dynalias.org/patches/
:
: 228664 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-14 04:46 EST by Vladimir N.Chernenkov
Modified: 2008-08-02 19:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-14 12:53:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vladimir N.Chernenkov 2007-02-14 04:46:02 EST
Description of problem:

If actual size of memory on motherboard is <=1024M 
the all work OK. You may boot kernel-2.6.19-1.2895.fc6 with mem=1024M and
bigger phyzical size of memory, then working ok too.
But for default loading of the kenels up to kernel-doc-2.6.20-1.2922.fc7 with
size of memory > 1G there is crashed by error in DMA operations.

Version-Release number of selected component (if applicable):
kernel-2.6.19-1.2895.fc6.x86_64, 
kernel-2.6.20-1.2922.fc7.x86_64

How reproducible:
Build the system with CPU AMD Opteron and 2048M of memory on
ASUS SK8N Motherboard with PCI TEW-403PI wireless adapter.

Steps to Reproduce:

1. Configure WiFi device BCM4306 802.11b/g with wpa_supplicant as eth1
2. modprobe bcm43xx 
3. service wpa_supplicant start

  
Actual results:


Expected results:


Additional info:
That problem is descrybed and resolved by Larry Finger`s patches:
ftp://lwfinger.dynalias.org/patches/
Comment 1 Vladimir N.Chernenkov 2007-02-14 04:59:12 EST
*** Bug 228664 has been marked as a duplicate of this bug. ***
Comment 2 John W. Linville 2007-02-14 08:44:02 EST
I have most of Larry's patches available in the test kernels here:

   http://people.redhat.com/linville/kernels/fc6/

Please give them a try and post the results here...thanks!
Comment 3 Vladimir N.Chernenkov 2007-02-14 12:53:01 EST
(In reply to comment #2)
> I have most of Larry's patches available in the test kernels here:
> 
>    http://people.redhat.com/linville/kernels/fc6/
> 
> Please give them a try and post the results here...thanks!

Ok, kernel-2.6.19-1.2895.6.1.fc6.jwltest.19.x86_64 is tested now, and is
workable for 2048MB of memory:
free
             total       used       free     shared    buffers     cached
Mem:       2038752     576064    1462688          0      47588     358604
-/+ buffers/cache:     169872    1868880
Swap:      2963952          0    2963952

dmesg | tail

bcm43xx: set security called, .active_key = 0, .level = 2, .enabled = 1, .encryp
t = 1
bcm43xx: set security called, .enabled = 1, .encrypt = 1
SoftMAC: Associate: Scanning for networks first.
SoftMAC: Start scanning with channel: 1
SoftMAC: Scanning 14 channels
bcm43xx: set security called, .enabled = 0, .encrypt = 0
bcm43xx: set security called, .enabled = 0, .encrypt = 0
bcm43xx: set security called, .level = 0, .enabled = 0, .encrypt = 0
bcm43xx: set security called, .level = 0, .enabled = 0, .encrypt = 0
bcm43xx: set security called, .level = 0, .enabled = 0, .encrypt = 0
SoftMAC: Scanning finished
SoftMAC: Queueing Authentication Request to 00:13:46:ff:0f:f7
SoftMAC: Cannot associate without being authenticated, requested authentication
SoftMAC: Sent Authentication Request to 00:13:46:ff:0f:f7.
SoftMAC: generic IE set to dd160050f20101000050f20201000050f20201000050f201
SoftMAC: Already associating or associated to 00:13:46:ff:0f:f7
SoftMAC: Open Authentication completed with 00:13:46:ff:0f:f7
SoftMAC: sent association request!
SoftMAC: associated!
bcm43xx: set security called, .active_key = 0, .level = 2, .enabled = 1, .encryp
t = 1
bcm43xx: set security called, .enabled = 1, .encrypt = 1
  
Comment 4 Chuck Ebbert 2007-02-15 14:19:11 EST
I really don't understand how this problem can be in the 2895 kernel,
because Larry's patch for the 1GB memory problem is already in
the kernel.org 2.6.19 kernel that we are based on.

What additional patch might we need?


Note You need to log in before you can comment on or make changes to this bug.