Bug 22868 - updated DRM modules needed
Summary: updated DRM modules needed
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact: Brock Organ
URL:
Whiteboard: Florence Beta-3
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-27 07:38 UTC by Jeremy Katz
Modified: 2007-04-18 16:30 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-12 18:19:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jeremy Katz 2000-12-27 07:38:48 UTC
Version drift between the XFree/DRI folks and the kernel folks

DRI in XFree 4.0.2 requires (at least for the r128 chip, and I'm pretty
sure for several others based on a few emails off of the DRI lists) an
updated DRM module as opposed to the revision 1.0 drm module currently in
the kernel tree; updated version of the modules should be in
xc/programs/Xserver/hw/xfree86/os-support/linux/drm/kernel/ of the XFree
tree.  Currently installed are XFree86-4.0.2-0.1 and kernel-2.4.0-0.43.11
from rawhide

Comment 1 Glen Foster 2001-01-11 21:14:59 UTC
This defect is considered MUST-FIX for Florence Gold release

Comment 2 Michael K. Johnson 2001-01-12 14:27:14 UTC
Bill, Mike, any objections?

Comment 3 Jeremy Katz 2001-01-12 18:19:43 UTC
Just to add some information here -- if you update to 2.4.0 final (or actually,
there may be a few necessary bits in one of the ac kernels since I seem to
remember a minor fix for one of the cards, Alan would know better), the DRM
modules there have the proper version to work with XFree 4.0.2

Comment 4 Michael K. Johnson 2001-01-15 22:18:41 UTC
Our current source tree is -ac4 based and will advance shortly to
a later kernel, so I'll close this as RAWHIDE on the theory that
by the time we build a kernel that makes it to rawhide, it will
have these modules...  :-)


Note You need to log in before you can comment on or make changes to this bug.