Bug 228814 - Rebooting with iSCSI target disks mounted results gets stalled.
Rebooting with iSCSI target disks mounted results gets stalled.
Status: CLOSED DUPLICATE of bug 223932
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: iscsi-initiator-utils (Show other bugs)
All Linux
medium Severity high
: ---
: ---
Assigned To: Mike Christie
Brock Organ
: 228815 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2007-02-15 04:15 EST by Shyam kumar Iyer
Modified: 2008-04-07 01:13 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-02-19 18:10:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Shyam kumar Iyer 2007-02-15 04:15:33 EST
Description of problem:
iSCSI target disks are mounted on the Server. On rebooting the server the 
reboot stops at synchronizing SCSI cache for the iSCSI target disk. iSCSI 
initiator connection times out and following message is displayed-
"iscsi: can not broadcast skb (-3)"
"connection0:0 iscsi: detected conn error (1011)"

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Initiate iSCSI initiator.
2. Mount iSCSI target's disk.
3. Reboot the system.
Actual results:
Reboot stalls at Sychronizing SCSI cache for the iSCSI target's disk.

Expected results:
Reboot should not stall.

Additional info:
Looks like since the network is stopped before the disks are unmounted the 
synchronize SCSI cache command fails obviously because of the network not 
being up.
Comment 1 Shyam kumar Iyer 2007-02-15 04:28:55 EST
*** Bug 228815 has been marked as a duplicate of this bug. ***
Comment 2 Andrius Benokraitis 2007-02-16 12:31:22 EST
Adding RH'ers responsible for Dell. Please confirm this is a bug, and add to
prioritization ASAP.
Comment 3 Mike Christie 2007-02-19 13:05:34 EST
I have this bug here:
Is it a problem in the kexec script.

I guess it was too late for RHEL 5.0. Could someone hit the "+" for 5.1?

Dell what target are you guys using btw?
Comment 4 Andrius Benokraitis 2007-02-19 18:10:20 EST

*** This bug has been marked as a duplicate of 223932 ***
Comment 5 Shyam kumar Iyer 2007-02-20 00:12:36 EST
Ok, the fix in BZ223932 works fine.
Comment 6 Andrius Benokraitis 2007-02-20 08:09:09 EST
Shyam, great to hear - from now on could you please use bug 223932 for comments?

Note You need to log in before you can comment on or make changes to this bug.