Bug 228856 - Can't print from KDE
Can't print from KDE
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
Depends On:
Blocks: FC6Update
  Show dependency treegraph
Reported: 2007-02-15 11:18 EST by Michael A. Peters
Modified: 2008-08-02 19:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-05-06 15:14:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
PDF file created from "Create a PDF File" that doesn't print (32.06 KB, application/pdf)
2007-02-16 09:17 EST, Michael A. Peters
no flags Details
output.ps (67.45 KB, application/postscript)
2007-02-19 13:10 EST, Tim Waugh
no flags Details
cups error log (2.45 KB, text/plain)
2007-04-17 11:30 EDT, Shaun Andrew
no flags Details

  None (edit)
Description Michael A. Peters 2007-02-15 11:18:07 EST
Description of problem:
This was working until just recently.
Printer: HP LaserJet 4 w/ Postscript L2 simm + 26 MB RAM (two on board + 3 8MB
dimms) + HP JetDirect card. Using "HP LaserJet 4 Plus v2013.111 Postscript
(recommended)" configuration.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Try to print document
Actual results:
The requesting user name, job ID, and document title appear on the LaserJet 4
display but nothing is printed.

Expected results:
Document should be printed.

Additional info:
Tried printing a text document from gedit. When that failed, I printed to PDF
file and tried printing from evince. Both cases same symptom.

However, printing a postscript file OUTSIDE of cups works via:

ttcp -p 9100 -t ip.of.your.printer <file.ps

So the printer is functional. Cups is sending the job information as I can see
it on the Printer display, it just is not printing.

This was working quite well just a few days ago. Something broke it :(
Comment 1 Tim Waugh 2007-02-15 11:37:34 EST
Could you try the test update (1.2.8-1.fc6) from updates-testing please?:

yum --enablerepo=updates-testing update 'cups*'

Also, what architecture are you using (i386, x86_64, something else)?
Comment 2 Michael A. Peters 2007-02-15 11:50:48 EST
I'm using i386

Updated from updates-testing
Identical symptom. Job number on printer incremented but nothing printed.
Comment 3 Tim Waugh 2007-02-15 12:05:49 EST
Okay, thanks.  Can you find out, using

  grep ^cups- /var/log/rpmpkgs*


  ls -l /var/log/rpmpkgs*

(to see the time stamps), what version and release of cups you were running
before things broke?  Thanks.
Comment 4 Michael A. Peters 2007-02-15 13:30:17 EST
Here is from one machine (laptop):
[mpeters@atlantis ~]$ grep ^cups- /var/log/rpmpkgs*
[mpeters@atlantis ~]$ ls -l /var/log/rpmpkgs*
-rw-r--r-- 1 root root 29092 Feb 15 04:26 /var/log/rpmpkgs
-rw-r--r-- 1 root root 28965 Feb 10 04:20 /var/log/rpmpkgs.1

Here is from other machine (Desktop):

[mpeters@jerusalem ~]$ grep "^cups-" /var/log/rpmpkgs*
[mpeters@jerusalem ~]$ ls -l /var/log/rpmpkgs*
-rw-r--r-- 1 root root 38053 Feb 15 04:51 /var/log/rpmpkgs
-rw-r--r-- 1 root root 37993 Feb 10 04:51 /var/log/rpmpkgs.1
-rw-r--r-- 1 root root 37371 Feb  3 04:51 /var/log/rpmpkgs.2

Both exhibit this symptom.

As another test just - just now on the desktop - I changed the driver to
Foomatic/hpijs and it then did succesfully print the test page. So it looks like
it is only a problem with the postscript driver.
Comment 5 Tim Waugh 2007-02-16 05:27:42 EST
Please fetch cups-1.2.7-1.7.fc6.i386.rpm and cups-libs-1.2.7-1.7.fc6.i386.rpm
from here:


and downgrade to them like this:

rpm -Uvh --oldpackage cups-*1.2.7-1.7.fc6.i386.rpm

Can you confirm that the bug was introduced in 1.2.7-1.8.fc6 (which you're now
running), or does 1.7 exhibit the same problem?
Comment 6 Michael A. Peters 2007-02-16 08:43:38 EST
It does work with 1.7
Comment 7 Michael A. Peters 2007-02-16 08:54:47 EST
Hold on - it seems to be a little more complicated.

The text document does not print from gedit, nor does the pdf file created from
text doc via print to pdf.

But web pages do, pdf files created from LaTeX do, etc.

I will try some other apps and with the current cups and cups-libs and see if I
can better figure out - may not be a cups bug at all (ghostscript ??)
Comment 8 Michael A. Peters 2007-02-16 09:07:38 EST
It seems that printing fails with every app and only apps that offer "Create a
PDF document" from the print dialog. PDF files created by those apps also fail.

Apps that do not offer that option can print, and PDF documents created from
LaTeX (TeXLive 2007 test release) do in fact print. Most of my printing is from
the latter so I unfortunately can't determine when it broke.
Comment 9 Michael A. Peters 2007-02-16 09:17:09 EST
Created attachment 148194 [details]
PDF file created from "Create a PDF File" that doesn't print

A pdf file created from gedit via "Create a PDF file" that does not print.
Submitted in case it can be of value determing the issue.
Comment 10 Tim Waugh 2007-02-19 13:09:38 EST
1. So, just to confirm: the problem has the same symptoms on both
cups-1.2.7-1.7.fc6 and cups-1.2.7-1.8.fc6 -- i.e. downgrading cups made no

2. I'm going to attach an 'output.ps', which is a PostScript version of the PDF
file from comment #9.  Please try printing it directly and let me know what happens:

ttcp -p 9100 -t ip.of.your.printer <output.ps
Comment 11 Tim Waugh 2007-02-19 13:10:09 EST
Created attachment 148353 [details]
Comment 12 Shaun Andrew 2007-04-03 09:07:00 EDT
I am unable to print to a HP LaserJet Printer from any and all systems running
fc6.  The KDE print manager will not even add the printer.
Comment 13 Tim Waugh 2007-04-03 09:08:56 EDT
Can you try following the instructions in comment #10 and reporting the results
Comment 14 Shaun Andrew 2007-04-03 12:02:50 EDT
(In reply to comment #13)
I downloaded and installed the ttcp utility and created a postscript file of a
source file using kate.

The kde print utility complains about its driver each time a print is requested.  
The error message is provided between the *****.

An error occurred while retrieving the printer list:

Connection to CUPS server failed. Check that the CUPS server is correctly
installed and running. Error: /var/run/cups/cups.sock: read failed (14).

"Print to File (PostScript)" is then offered by the print utility and I saved
the generated output to output.ps

I then submited output.ps per ttcp as you requested.  (The stats outputed by
ttcp are below.)  THE PRINT JOB LOOKED GREAT! 

[root@boss sandrew]# ttcp -p 9100 -t <output.ps

ttcp-t: buflen=8192, nbuf=2048, align=16384/0, port=9100  tcp  ->
ttcp-t: socket
ttcp-t: connect
ttcp-t: 415177 bytes in 24.19 real seconds = 16.76 KB/sec +++
ttcp-t: 51 I/O calls, msec/call = 485.67, calls/sec = 2.11
ttcp-t: 0.0user 0.0sys 0:24real 0% 0i+0d 0maxrss 0+3pf 47+0csw

I am new bugzilla.  After I created and submitted my output.ps, I then found
where bugzilla list its attachments.  I then submitted your output.ps

[root@boss ttcp]# ttcp -p 9100 -t <output.ps

ttcp-t: buflen=8192, nbuf=2048, align=16384/0, port=9100  tcp  ->
ttcp-t: socket
ttcp-t: connect
ttcp-t: 69065 bytes in 1.12 real seconds = 60.12 KB/sec +++
ttcp-t: 9 I/O calls, msec/call = 127.65, calls/sec = 8.02
ttcp-t: 0.0user 0.0sys 0:01real 0% 0i+0d 0maxrss 0+3pf 7+0csw

Comment 15 Tim Waugh 2007-04-03 12:14:18 EDT
"Connection to CUPS server failed." - Your CUPS server isn't running.  What does
'/sbin/service cups status' say?
Comment 16 Shaun Andrew 2007-04-03 12:51:42 EDT
(In reply to comment #15)

This is why it is so fustrating... (It all worked fine under fc5.)

[root@boss ttcp]# /sbin/service cups status

cupsd (pid 2395) is running...

Comment 17 Tim Waugh 2007-04-03 13:09:08 EDT
What does this say?:

egrep '^(Listen)|(Port)' /etc/cups/cupsd.conf
Comment 18 Shaun Andrew 2007-04-03 14:23:44 EDT
(In reply to comment #17)

[root@boss ttcp]# egrep '^(Listen)|(Port)' /etc/cups/cupsd.conf

# Ports/addresses that we listen to.  The default port 631 is reserved
# You can have multiple Port/Listen lines to listen to more than one
#    Port 80
#    Port 631
# must have at least one Port or Listen line that allows access from the
#Port 80
#Port 443
# BrowsePort: the port used for UDP broadcasts.  By default this is
# Only one BrowsePort is recognized.
#BrowsePort 631

Comment 19 Tim Waugh 2007-04-10 07:29:09 EDT
This seems to be a KDE bug.  The CUPS server isn't listening on the UNIX domain
socket, but KDE is trying to use that anyway (and doesn't fall back to

Just to be sure, what does 'lpstat -s' say?
Comment 20 Shaun Andrew 2007-04-16 15:24:53 EDT
(In reply to comment #19)
[root@boss ~]# lpstat -s
lpstat: Unable to connect to server
Comment 21 Tim Waugh 2007-04-16 17:48:29 EDT
And '/sbin/service cups status' says cupsd is running even when 'lpstat -s' says
it can't connect?

Could you attach /var/log/cups/error_log please?
Comment 22 Shaun Andrew 2007-04-17 11:30:05 EDT
Created attachment 152823 [details]
cups error log
Comment 23 Tim Waugh 2007-04-18 12:37:56 EDT
But the server isn't running:

I [17/Apr/2007:07:59:07 -0500] Scheduler shutting down normally.
I [17/Apr/2007:07:59:07 -0500] Saving remote.cache...

What does 'chkconfig --list cups' say?
Comment 24 Bug Zapper 2008-04-04 02:14:59 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 25 Bug Zapper 2008-05-06 15:14:14 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.