Bug 228879 - Intel HDA Sound lost on 2.6.19-*
Intel HDA Sound lost on 2.6.19-*
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-15 13:42 EST by Bart Couvreur
Modified: 2011-12-13 17:28 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.6.20-1.2933.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-26 16:20:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
System-config-sound log (45.17 KB, text/plain)
2007-02-15 13:42 EST, Bart Couvreur
no flags Details

  None (edit)
Description Bart Couvreur 2007-02-15 13:42:32 EST
Description of problem:

After upgrading to 2.6.19-* all sound was lost.

Version-Release number of selected component (if applicable):
-kernel 2.6.19-1.2895.fc6
-kernel 2.6.19-1.2911.fc6
-alsa-utils-1.0.13-1.fc6
-alsa-lib-1.0.13-1.fc6
-alsa-tools-1.0.12-4.fc6
-alsa-lib-devel-1.0.13-1.fc6

How reproducible:
Always

Actual results:
No sound

Expected results:
To hear something

Additional info:

Relevant part of dmesg:
ACPI: PCI Interrupt 0000:00:1b.0[A] -> GSI 16 (level, low) -> IRQ 16
PCI: Setting latency timer of device 0000:00:1b.0 to 64
si3054: cannot initialize. EXT MID = 0000
ACPI: PCI interrupt for device 0000:00:1b.0 disabled
HDA Intel: probe of 0000:00:1b.0 failed with error -13

-> Attached scsconfig.log aswell
Comment 1 Bart Couvreur 2007-02-15 13:42:32 EST
Created attachment 148131 [details]
System-config-sound log
Comment 2 Chuck Ebbert 2007-02-15 16:05:54 EST
Found the patch for this; it's in 2.6.20

# HG changeset patch
# User Takashi Iwai <tiwai@suse.de>
# Date 1166601341 -3600
# Node ID d53318ba5eb26fbefb63d85c402cb368096436f3
# Parent e20d24388f86121d3ac6f58560e3b7acd686fd39
[ALSA] hda-codec - Don't return error at initialization of modem codec

Some modem codec seem to fail in the initialization, and this
stopped loading of the whole module although the audio is OK.
Since it's usually a non-fatal issue, the driver tries to proceed
to initialize now.

Signed-off-by: Takashi Iwai <tiwai@suse.de>
Signed-off-by: Jaroslav Kysela <perex@suse.cz>

committer: Jaroslav Kysela <perex@server.perex.cz> 1166601341 +0100

--- a/sound/pci/hda/patch_si3054.c	Wed Dec 20 08:55:39 2006 +0100
+++ b/sound/pci/hda/patch_si3054.c	Wed Dec 20 08:55:41 2006 +0100
@@ -243,7 +243,8 @@ static int si3054_init(struct hda_codec 
 
 	if((val&SI3054_MEI_READY) != SI3054_MEI_READY) {
 		snd_printk(KERN_ERR "si3054: cannot initialize. EXT MID = %04x\n", val);
-		return -EACCES;
+		/* let's pray that this is no fatal error */
+		/* return -EACCES; */
 	}
 
 	SET_REG(codec, SI3054_GPIO_POLARITY, 0xffff);
Comment 3 Chuck Ebbert 2007-02-23 09:37:08 EST
This should be fixed in the latest kernel, 2911.6.3, available at:

http://download.fedora.redhat.com/pub/fedora/linux/core/updates/testing/6/

Please test.
Comment 4 Russ Price 2007-03-13 19:08:58 EDT
Sound worked OK on 2911.6.4, but disappeared on 2911.6.5.

The only clue to any problem in dmesg:

   hda-intel: no codecs initialized

System: Intel D101GGC motherboard, Celeron D 336 CPU
Running the x86_64 version of FC6.

Workaround: continue running 2911.6.4.
Comment 5 Chuck Ebbert 2007-03-26 16:20:50 EDT
Fixed in 2.6.20-1.2933.fc6

Note You need to log in before you can comment on or make changes to this bug.