Bug 2290 - procmail no longer reads group-writable .procmailrc's
Summary: procmail no longer reads group-writable .procmailrc's
Status: CLOSED DUPLICATE of bug 2242
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: procmail (Show other bugs)
(Show other bugs)
Version: 5.2
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Keywords:
: 2291 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-04-20 20:01 UTC by Jim Knoble
Modified: 2008-05-01 15:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-06-07 23:32:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jim Knoble 1999-04-20 20:01:25 UTC
According to procmail's HISTORY file, procmail-3.12
introduced a new behavior with respect to group-writable
.procmailrc files and .procmailrc files located in
group-writable directories.  Specifically, procmail ignores
such a .procmailrc unless GROUP_PER_USER has been defined in
config.h at compile-time.

The most recent procmail update packages (3.13.1) do not
have GROUP_PER_USER defined and fail to function properly on
Red Hat Linux systems.

Comment 1 Bill Nottingham 1999-04-21 15:34:59 UTC
*** Bug 2291 has been marked as a duplicate of this bug. ***

According to procmail's HISTORY file, procmail-3.12
introduced a new behavior with respect to group-writable
.procmailrc files and .procmailrc files located in
group-writable directories.  Specifically, procmail ignores
such a .procmailrc unless GROUP_PER_USER has been defined in
config.h at compile-time.

The most recent procmail update packages (3.13.1) do not
have GROUP_PER_USER defined and fail to function properly on
Red Hat Linux systems.

Comment 2 Jeff Johnson 1999-06-07 23:32:59 UTC
*** This bug has been marked as a duplicate of 2242 ***


Note You need to log in before you can comment on or make changes to this bug.