Bug 229005 - loader received SIGSEGV!
Summary: loader received SIGSEGV!
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: dhcpv6   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: David Cantrell
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-16 14:16 UTC by Marius Andreiana
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-16 20:36:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Marius Andreiana 2007-02-16 14:16:56 UTC
Tried to install today's rawhide on Dell Latitude 620 with images/boot.iso and
HTTP install.
After getting DHCP IP I get
loader received SIGSEGV! Backtrace: ...

Alt+F3 shows
DHCP info ok
ERROR failed to get a DUID
INFO doesn't support eth0

Comment 1 David Cantrell 2007-02-16 15:55:56 UTC
You can get around this for now by disabling IPv6 in the loader.

Working on it now.

Comment 2 David Cantrell 2007-02-16 20:36:18 UTC
Problem was that the control socket opened in gethwid() in libdhcp6client was
being closed before the ioctl() calls were run.

Fixed in dhcpv6-0.10-40.  Reassigning this to the dhcpv6 component, since that's
where the problem was.

Thanks.


Note You need to log in before you can comment on or make changes to this bug.