Bug 22906 - php split to php and mod_php; problems when upgrading
Summary: php split to php and mod_php; problems when upgrading
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: php   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Need Real Name
URL:
Whiteboard: Florence Beta-3
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-27 22:23 UTC by Pekka Savola
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-11 21:16:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pekka Savola 2000-12-27 22:23:20 UTC
php has been split to mod_php and php.  This causes huge problems as it is,
mainly because the only real use for php previously was www scripting (ie: mod_php
functionality).

If you upgrade php, mod_php is not required and suddenly all your .php scripts
stop to work in apache... until you figure out you must install mod_php too.  
Highly undesirable.


This could be fixed as follows in RPM (triggers?):

1) if upgrading from earlier than php-4.0.1pl2-9, Require mod_php.
[I wonder how this could really be done??]
  
or

2) Require: mod_php in apache.. Well, not a real solution as not everybody
wants to install it.

or ???

Installer magic is _not_ an option as very many people upgrade without it.

Comment 1 Nalin Dahyabhai 2000-12-29 19:17:14 UTC
The rename was made when both the distribution and the package itself were
seeing major version changes.  All the same, it should have been in the release
notes.

Comment 2 Glen Foster 2001-01-11 21:16:10 UTC
This defect is considered MUST-FIX for Florence Gold release

Comment 3 Nalin Dahyabhai 2001-01-18 17:24:27 UTC
The mod_php package is being re-merged into php-4.0.4pl1-1.


Note You need to log in before you can comment on or make changes to this bug.