Bug 229072 - /usr/bin/boo{c,i,ish} point to assemblies in /usr/lib, not /usr/lib64
/usr/bin/boo{c,i,ish} point to assemblies in /usr/lib, not /usr/lib64
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: boo (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul F. Johnson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-16 14:56 EST by Paul T. Darga
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-17 19:18:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Paul T. Darga 2007-02-16 14:56:20 EST
Description of problem:

Boo shell scripts point to /usr/lib but assemblies live in /usr/lib64.

Version-Release number of selected component (if applicable):
0.7.6.2237-11.fc6

e.g. /usr/bin/booc reads:

#!/bin/sh
env mono /usr/lib/boo/booc.exe "$@"

However, booc.exe is in /usr/lib64/boo.
Comment 1 Paul F. Johnson 2007-02-16 15:07:25 EST
Yep - fixed in rawhide (just use that version). There is a problem with the PPC
mono on the buildsys which is preventing mono apps being built currently.
Comment 2 Paul T. Darga 2007-02-16 15:28:57 EST
I just did an update from extras-development, and the /usr/bin files in question
now have ${libdir} in them, which would seem to be a packaging problem, since I
don't have libdir in my environment.  Of course it should be the literal
/usr/lib64.  The source rpm must be busted...
Comment 3 Paul F. Johnson 2007-02-16 16:04:59 EST
What's the version number of the rpm?
Comment 4 Paul T. Darga 2007-02-16 16:09:39 EST
A yum fairy whispered 0.7.6.2237-12.fc7 in my ear.

Note You need to log in before you can comment on or make changes to this bug.