Bug 229116 - %{pyver} is undefined, but the requirement isn't needed
%{pyver} is undefined, but the requirement isn't needed
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mod_python (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-17 06:25 EST by Robert Scheck
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 3.3.1-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-20 07:48:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2007-02-17 06:25:35 EST
Description of problem:
> rpm -qp --requires http://download.fedora.redhat.com/pub/fedora/linux/core/
development/i386/os/Fedora/RPMS/mod_python-3.3.1-2.i386.rpm | grep python
config(mod_python) = 3.3.1-2
libpython2.5.so.1.0
python(abi) = 2.5
python-abi = %{pyver}
> 

Version-Release number of selected component (if applicable):
mod_python-3.3.1-2

Actual results:
%{pyver} is undefined, but the requirement itself isn't needed.

Expected results:
Either define %{pyver} or drop the requirement as it is more or less redundant 
because of the self-generated by rpm one:

--- mod_python.spec     2007-02-16 18:47:47.000000000 +0100
+++ mod_python.spec.rsc 2007-02-17 12:24:44.000000000 +0100
@@ -13,7 +13,7 @@
 Group: System Environment/Daemons
 BuildRequires: httpd-devel >= 2.0.40-6, python, python-devel
 Requires: httpd-mmn = %(cat %{_includedir}/httpd/.mmn || echo missing)
-Requires: python-abi = %{pyver}, httpd >= 2.0.40
+Requires: httpd >= 2.0.40
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)

 %description
Comment 1 Robert Scheck 2007-02-20 07:48:12 EST
Fixed by Jeremy in today's Rawhide in 3.3.1-3, closing now.

Note You need to log in before you can comment on or make changes to this bug.