Bug 229173 - The fullscreen panel stays on screen even when on different workspace
The fullscreen panel stays on screen even when on different workspace
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: evince (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marek Kašík
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-19 03:22 EST by Jan Pazdziora
Modified: 2010-03-30 04:03 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Fullscreen mode allows a user to view (in a maximized window) just the document and a single navigation toolbar. Previously, the function that handles the timeout of fullscreen mode was only made aware of the window, rather than the workspace. Consequently, if a user switched to a different workspace while fullscreen mode was enabled, the fullscreen toolbar would persist the top of the screen. With this update, the evince fullscreen toolbar no longer remains after changing workspaces, resolving this issue. (BZ#229173)
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-30 04:03:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A screenshot of the panel being shown on other workspace than the one where evince is fullscreened. (30.52 KB, image/png)
2007-02-19 03:22 EST, Jan Pazdziora
no flags Details

  None (edit)
Description Jan Pazdziora 2007-02-19 03:22:55 EST
Description of problem:

When you switch evince to fullscreen mode, moving your mouse will popup a
"panel" with buttons to go to the previous or next page, change zoom, and to
leave the fullscreen mode. When you switch to a difference workspace, the panel
stays on screen, and it does not even go away after a timeout (like it does when
you're on the same workspace as the evince fullscreened application).

Version-Release number of selected component (if applicable):

evince-0.6.0-8.el5

How reproducible:

Always.

Steps to Reproduce:
1. Open a document in evince.
2. Fullscreen it (via menu or F11).
3. Move a mouse to see the fullscreen panel to appear at the top of the page.
4. Wait for it to timeout and go away.
5. Switch to different workspace.
  
Actual results:

The panel will appear and will not go away.

Expected results:

There should be no panel on other workspaces.

Additional info:

The fullscreen panel should be tied to the application it works on. On other
workspaces it obscructs their menus, and it does not make sense to have a panel
controlling application on different workspace.
Comment 1 Jan Pazdziora 2007-02-19 03:22:55 EST
Created attachment 148313 [details]
A screenshot of the panel being shown on other workspace than the one where evince is fullscreened.
Comment 2 Jan Pazdziora 2007-03-28 04:36:14 EDT
As the bug is present in RHEL 5 as well, I'm changing the Product to reflect that.
Comment 3 RHEL Product and Program Management 2007-06-05 16:36:43 EDT
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Since this
bugzilla is in a component that is not approved for the current
release, it has been closed with resolution deferred.  You may
reopen this bugzilla for consideration in the next release.
Comment 4 Jan Pazdziora 2007-06-05 16:39:43 EDT
Reopening for consideration in the next release.
Comment 5 RHEL Product and Program Management 2007-12-03 15:41:10 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release.  This request will
be reviewed for a future Red Hat Enterprise Linux release.
Comment 6 Jan Pazdziora 2007-12-04 15:03:40 EST
Based on email:

Your options include:

1.  propose bugzilla for 5.2 FasTrack (fast flag) for low/medium
     priority non-FutureFeature and non-HardwareEnablement
2.  propose bugzilla for 5.2 exception requesting package be added to
     approved component list
3.  propose bugzilla for 5.3
4.  propose bugzilla for 6
5.  close bugzilla

I chose option 3.

Note -- this might not be a problem in evince -- it might turn out to be problem
with xorg-x11 or gtk or gnome or some other package. It's a pity the bugzilla
was ruled out from RHEL 5.2 before it ever got a chance to be seen by developer. 

FWIW, the problem is not present in F8.
Comment 8 RHEL Product and Program Management 2009-03-26 12:56:30 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 9 Jan Pazdziora 2009-03-26 13:05:39 EDT
Putting to queue for RHEL 5.5.
Comment 13 Ryan Lerch 2010-03-10 18:39:00 EST
Technical note added. If any revisions are required, please edit the "Technical Notes" field
accordingly. All revisions will be proofread by the Engineering Content Services team.

New Contents:
Fullscreen mode allows a user to view (in a maximized window) just the document and a single navigation toolbar. Previously, the function that handles the timeout of fullscreen mode was only made aware of the window, rather than the workspace. Consequently, if a user switched to a different workspace while fullscreen mode was enabled, the fullscreen toolbar would persist the top of the screen. With this update, the evince fullscreen toolbar no longer remains after changing workspaces, resolving this issue. (BZ#229173)
Comment 14 errata-xmlrpc 2010-03-30 04:03:00 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0195.html

Note You need to log in before you can comment on or make changes to this bug.