Bug 229202 - (CVE-2007-0898) 0.90 fixes CVE-2007-0897 (MIME Header Handling) and CVE-2007-0898 (CAB File Processing) Denials of Service
0.90 fixes CVE-2007-0897 (MIME Header Handling) and CVE-2007-0898 (CAB File P...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: clamav (Show other bugs)
6
All Linux
high Severity urgent
: ---
: ---
Assigned To: Enrico Scholz
Fedora Extras Quality Assurance
http://secunia.com/advisories/24187
: Security
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-19 10:50 EST by Peter Gordon
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.88.7-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-22 05:17:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Gordon 2007-02-19 10:50:08 EST
According to Secunia:
"Two vulnerabilities have been reported in ClamAV, which can be exploited by
malicious people to cause a DoS (Denial of Service).

1) Input passed via the "id" parameter when parsing MIME headers is not properly
sanitised before being used to create local files. This can be exploited to e.g.
overwrite the anti-virus signature file via directory traversal attacks,
preventing malware from being detected.

2) An file descriptor leak error in the processing of CAB files can be exploited
to e.g. prevent legitimate users from sending out valid archives via a specially
crafted CAB file with a cabinet header containing a record length of zero."

Please update the FC-6 package to version 0.90 to fix these. Thanks.
Comment 1 Bas Mevissen 2007-02-22 04:05:43 EST
This update will also fix the following warning in the logs:

Last Status:
    WARNING: Your ClamAV installation is OUTDATED!
    WARNING: Local version: 0.88.7 Recommended version: 0.90
    DON'T PANIC! Read http://www.clamav.net/faq.html
    main.cvd is up to date (version: 42, sigs: 83951, f-level: 10, builder: tkojm)
    daily.cvd updated (version: 2623, sigs: 9598, f-level: 13, builder: ccordes)
    WARNING: Your ClamAV installation is OUTDATED!
    WARNING: Current functionality level = 10, recommended = 13
    DON'T PANIC! Read http://www.clamav.net/faq.html
    Database updated (93549 signatures) from db.NL.clamav.net (IP: 145.58.27.1
Comment 2 Enrico Scholz 2007-02-22 05:17:00 EST
CVEs should be fixed by 0.88.7-2; freshclam warning is only a warning and I do
not plan to update version FC-5/6 to 0.90
Comment 3 Bas Mevissen 2007-02-23 03:48:07 EST
Hmmm, I regard this as quite lousy...
Comment 4 Jason Tibbitts 2007-02-23 10:21:16 EST
Why?  Maintenance is not about always pushing out the absolute latest version.

If you have a compelling argument to make regarding why all machines should get
0.90 then please make it.  If you have questions about why 0.90 is not
appropriate to push out to all machines then please ask them.

The bottom line is that it is the maintainer's decision.  You can always grab
the devel SRPM or check the source out from CVS and build it yourself if you
disagree.
Comment 5 Ville Skyttä 2007-02-25 08:41:30 EST
Enrico, there are references and patches related to CVE-2007-0899 in the
0.88.7-2 update, however I'm not able to find any real info about that CVE
anywhere; in MITRE it's just reserved, and in NVD it's empty.  Any links to
publicized info about the issue?
Comment 6 Enrico Scholz 2007-02-25 09:12:06 EST
I took it from the Debian changelog

| [CVE-2007-0899] Possible heap overflow in libclamav/fsg.c

I do not have more details.

Note You need to log in before you can comment on or make changes to this bug.