Bug 229286 - Solaris build: link shared libs correctly with libtool
Solaris build: link shared libs correctly with libtool
Status: CLOSED CURRENTRELEASE
Product: 389
Classification: Community
Component: Directory Server (Show other bugs)
1.0.4
All Other
medium Severity medium
: ---
: ---
Assigned To: Rich Megginson
Viktor Ashirov
:
Depends On:
Blocks: 152373 240316 FDS1.1.0
  Show dependency treegraph
 
Reported: 2007-02-19 17:44 EST by Rich Megginson
Modified: 2015-12-07 12:01 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 12:01:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
diffs (5.29 KB, patch)
2007-02-19 17:57 EST, Rich Megginson
no flags Details | Diff
cvs commit log (1.59 KB, text/plain)
2007-02-19 18:55 EST, Rich Megginson
no flags Details

  None (edit)
Description Rich Megginson 2007-02-19 17:44:48 EST
We have to use $(CXXLINK) on Solaris to link libcollation and libacl since they
link with C++ libraries.
Comment 1 Rich Megginson 2007-02-19 17:57:48 EST
Created attachment 148375 [details]
diffs
Comment 2 Nathan Kinder 2007-02-19 18:43:16 EST
Looks good.
Comment 3 Rich Megginson 2007-02-19 18:55:54 EST
Created attachment 148378 [details]
cvs commit log

Reviewed by: nkinder, prowley (Thanks!)
Files: see diff
Branch: HEAD
Fix Description: We have to use the $(CXXLINK) Makefile macro to build shared
libs that use C++ code or link with C++ libs.  In addition, Sun C++ link needs
-lCstd and -lCrun.  I added AC_DISABLE_STATIC so that we wouldn't generate all
the .a libs we don't use.  Lastly, but not leastly, libtool on rhel/fedora has
a "feature" that adds several gcc-isms to the libtool script generated by
configure.  At best, these cause builds with non-gcc compilers to complain
quite a bit, and at worst, cause the build to fail.  I've added a sed command
in configure to remove these gcc-isms from libtool on non-gcc platforms.
Platforms tested: RHEL4, FC6, Solaris 9
Flag Day: no
Doc impact: no
Comment 4 Nathan Kinder 2007-12-21 14:08:17 EST
Verified that libacl-plugin.so and libcollation-plugin.so are linked with the C
runtime libraries on Solaris.

Marking as VERIFIED.

Note You need to log in before you can comment on or make changes to this bug.