Bug 229302 - DPMS not enabled, but it is in xorg.conf and in driver
DPMS not enabled, but it is in xorg.conf and in driver
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-19 21:50 EST by Rob Arnold
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-02 12:51:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the xorg.conf requested (2.27 KB, application/octet-stream)
2007-03-01 19:54 EST, Rob Arnold
no flags Details
x log (28.86 KB, text/plain)
2007-03-01 19:58 EST, Rob Arnold
no flags Details
x log from default no xorg.conf (28.86 KB, text/plain)
2007-03-01 20:05 EST, Rob Arnold
no flags Details

  None (edit)
Description Rob Arnold 2007-02-19 21:50:46 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Rob Arnold 2007-02-19 22:03:20 EST
Bah, posted too early accidently.

Report is:
X seems to not have the dpms extension enabled when it starts up, despite it being in the xorg.conf, 
and being recognized by the driver.  I see no errors in the /var/log/Xorg.0.log, but when I do an xset 
+dpms, or any other command that requires the X server have dpms functionality, I get error messages.

More details:
Fedora Core 6 install, completely yum updated as of now.

In the xorg.conf, I have dpms turned on in the Monitor sections:
    Option         "DPMS"
I also tried Option "dpms" in case case sensitivity changed, but neither made a difference, and both 
used to work on earlier Fedora Core 5 and previous installs. 


In the Xorg.0.log file, I see that the option is read and acted on by the driver by lines such as:
(**) Option "dpms"
(**) NVIDIA(0): DPMS enabled

There is also a couple lines like the above for the other head of the display, NVIDIA(1)


If I run xset q, the dpms section says:
DPMS (Energy Star):
  Server does not have the DPMS Extension

Likewise:
# xset +dpms
server does not have extension for +dpms option

and so on for any of the other dpms commands.

I've searched, but can't find anyone else with a mention of DPMS being always *off*  (found some 
people having trouble with it being enabled no matter what).

Comment 2 Matěj Cepl 2007-02-28 11:26:55 EST
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Rob Arnold 2007-03-01 19:54:19 EST
Created attachment 149076 [details]
the xorg.conf requested
Comment 4 Rob Arnold 2007-03-01 19:58:16 EST
Created attachment 149077 [details]
x log

Note that dpms is enabled in the log
Comment 5 Rob Arnold 2007-03-01 20:05:41 EST
Created attachment 149079 [details]
x log from default no xorg.conf

Appears that DPMS is on using defaults... odd.
Comment 6 Rob Arnold 2007-03-01 20:12:31 EST
I've attached the files as requested.  Note that in the time since I filed this bug, I have recompiled the 
kernel and also the video driver glue from nvidia.  I get the same results in terms of dpms.  It looks like 
there is an issue with XVideo as well (I do think XVideo worked at the time I filed the issue, but am not 
positive).

When I submitted the original issue, I was using the stock FC6 kernel and xorg, yum updated to that day, 
plus the nvida driver closed source driver (which had always worked for me before, and reports dpms as 
enabled in the X log).  
Comment 7 Matěj Cepl 2007-03-02 12:51:22 EST
Thanks for the report.  For users who are experiencing problems
installing, configuring, or using the unsupported 3rd party
proprietary "nvidia" video driver, Nvidia provides indirect
customer support via an online web based support forum.  Nvidia
monitors these web forums for commonly reported problems and
passes them on to Nvidia engineers for investigation.  Once
they've isolated a particular problem, it is often fixed in
a future video driver update.

The NVNews Nvidia Linux driver forum is located at:

    http://www.nvnews.net/vbulletin/forumdisplay.php?s=&forumid=14

Once you have reported this issue in the Nvidia web forums,
others who may have experienced the particular problem may
be able to assist.  If there is a real bug occuring, Nvidia
will be able to determine this, and will likely resolve the
issue in a future driver update for the operating system
releases that they officially support.

While Red Hat does not support the proprietary nvidia driver,
users requiring technical support may also find the various
X.Org, XFree86, and Red Hat mailing lists helpful in finding
assistance:

X.Org mailing lists:
    http://www.freedesktop.org/XOrg/XorgMailingLists

XFree86 mailing lists:
    http://www.xfree86.org/sos/lists.html

Red Hat mailing lists:
    https://listman.redhat.com/mailman/listinfo

Setting status to "CANTFIX" (unsupported).
Comment 8 Rob Arnold 2007-03-02 22:05:43 EST
Well, after posting logs here and with Nvidia, and going back and forth trying lots of things, the what 
should have been obvious was pointed out.  Look at my modules section in the attached xorg.conf file.  
Somehow my original list of modules had been truncated.  In particular, extmod was missing.  This caused 
the issue.


Note You need to log in before you can comment on or make changes to this bug.