Bug 229341 - libatk-bridge.so: undefined symbol: atk_misc_get_instance
libatk-bridge.so: undefined symbol: atk_misc_get_instance
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: at-spi (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-20 09:21 EST by Marius Andreiana
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-25 10:56:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marius Andreiana 2007-02-20 09:21:08 EST
Description of problem:
tried to run vmware player, it gives:

GThread-ERROR **: GThread system may only be initialized once.
aborting...
Gtk-Message: Failed to load module "gail": /usr/lib/gtk-2.0/modules/libgail.so:
undefined symbol: atk_misc_instance
/usr/lib/vmware/bin/vmplayer: symbol lookup error:
/usr/lib/gtk-2.0/modules/libatk-bridge.so: undefined symbol: atk_misc_get_instance

Looks like it's atk's fault
Comment 1 Matthias Clasen 2007-02-22 23:34:45 EST
What version of atk do you have installed ?

atk_misc_get_instance was added in atk 1.13. I've bumped the atk requirement to
that version now.
Comment 2 Marius Andreiana 2007-02-24 11:11:07 EST
atk-1.17.0-1.fc7
Still doesn't work with current rawhide.
Comment 3 Matthias Clasen 2007-02-24 17:46:32 EST
not clear to me what is happening here. 

[mclasen@localhost atk-1.17.0]$ nm -D /usr/lib/gtk-2.0/modules/libgail.so | grep atk
         U atk_misc_get_type
         U atk_misc_instance

[mclasen@localhost atk-1.17.0]$ nm -D /usr/lib/libatk-1.0.so.0 | grep atk_misc
0587e170 T atk_misc_get_instance
0587e190 T atk_misc_get_type
058877e0 B atk_misc_instance
0587e130 T atk_misc_threads_enter
0587e150 T atk_misc_threads_leave

Certainly looks to me like libatk is providing what gail needs.
Comment 4 Marius Andreiana 2007-02-25 02:58:00 EST
I get the same.

If you think it's vmplayer's fault, please close this. I haven't got a reply
from them:
http://www.vmware.com/community/thread.jspa?threadID=73165&tstart=0
It looks like it's vmplayer, since other gnome/gtk apps are working ok.

Thanks
Comment 5 Matthias Clasen 2007-02-25 10:56:02 EST
Thanks for that information; closing then. 

Note You need to log in before you can comment on or make changes to this bug.