Bug 229372 - usernetctl preserves original gid and egid
usernetctl preserves original gid and egid
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-20 12:50 EST by Miloslav Trmač
Modified: 2014-03-16 23:05 EDT (History)
1 user (show)

See Also:
Fixed In Version: 8.53-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-19 15:56:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miloslav Trmač 2007-02-20 12:50:01 EST
usernetctl currently does nothing with the gid and egid of the invoking user, so
/sbin/ifup and all further processes are executed with gid of the invoking user.
 This seems to be potentially insecure (e.g. creating files readable and
writable by the invoking user);  currently this causes a SELinux denial in the
following situation:

Steps to Reproduce:
1.eth0 has USERNETCTL=yes, BOOTPROTO=dhcp
2.user runs /sbin/ifup eth0
3.this eventually runs /sbin/dhclient-script, with egid=$user euid=0
  gid=$user uid=0
4.this eventually runs (cp -fp /etc/resolv.conf /etc/resolv.conf.predhclient)
5.cp creates /etc/resolv.conf.predhclient, which is now owned by root:$user
6.cp attempts to fchown()s /etc/resolv.conf.predhclient to root:root, which is
  prohibited by SELinux

Version-Release number of selected component (if applicable):
initscripts-8.45.7-1
Comment 1 Bill Nottingham 2007-04-19 15:56:16 EDT
Fixed, will be in 8.53-1.

Note You need to log in before you can comment on or make changes to this bug.