Bug 22940 - backwards compatibility with bash
Summary: backwards compatibility with bash
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: bash   
(Show other bugs)
Version: 7.0J
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-28 14:06 UTC by Stefan
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-28 16:00:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Stefan 2000-12-28 14:06:30 UTC
Can't do condition statements like the following anymore :
[ $? -eq 0 ] && { echo "Great stuff" }
This used to work in bash but now bash2 requires something like :
[ $? -eq 0 ] && { echo "Great stuff"; }

This caused half the scripts on my machine not to work
anymore after I upgraded to Redhat 7 final, because there
is now only bash2.

Comment 1 Bill Nottingham 2000-12-28 16:00:09 UTC
It's an error in the script. bash1 was slightly more lenient.


Note You need to log in before you can comment on or make changes to this bug.