Bug 229409 - Print.h missing in /usr/include/X11/extensions/
Print.h missing in /usr/include/X11/extensions/
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-proto-devel (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-20 16:00 EST by Eric Majzoub
Modified: 2011-10-19 10:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-28 11:24:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Eric Majzoub 2007-02-20 16:00:39 EST
Description of problem:

FC6 is missing:
/usr/include/X11/extensions/Print.h

Causes problems compiling programs using the OpenMotif and/or Lesstif API.

Version-Release number of selected component (if applicable):

Xorg version 7.1 shipping with FC6

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

I submitted this as a bug at the request of the maintainer of the plotting
program XMGrace.
Comment 1 Adam Jackson 2007-02-28 11:24:23 EST
The Xprint support is deprecated.  The extension headers are available in
libXp-devel if you really need them, but since most modern linux systems do not
ship an Xprint server applications are encouraged to find other solutions for
printing.

'yum install /usr/include/X11/extensions/Print.h' would have found that package
for you, btw.
Comment 2 Wharton Sinkler 2011-10-19 10:01:04 EDT
I am encountering the same problem, trying to install openmotif 2.3.1 on Red Hat Enterprise Linux Server 5.6 (Tikanga).  

Compilation fails because /usr/include/X11/extensions/Print.h is included in the Xm.h header file for Motif.  

I also cannot use 'yum install ...' because that reports that Print.h is not available, possibly because RHN support is not registered (not even sure what this is but found somewhere that it needs to be registered at the time the system is set up, which is too late now).  

Any ideas how I can move forward on installing openmotif (get around this missing file issue)?  

Thanks,
Wharton

Note You need to log in before you can comment on or make changes to this bug.