This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 229428 - ns-slapd not linking to C++ runtime on HP-UX
ns-slapd not linking to C++ runtime on HP-UX
Status: CLOSED CURRENTRELEASE
Product: 389
Classification: Community
Component: Directory Server (Show other bugs)
7.1
All Other
medium Severity medium
: ---
: ---
Assigned To: Nathan Kinder
Viktor Ashirov
:
Depends On:
Blocks: 152373 240316 FDS1.1.0
  Show dependency treegraph
 
Reported: 2007-02-20 18:18 EST by Nathan Kinder
Modified: 2015-12-07 12:16 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 12:16:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Proposed Fix (846 bytes, patch)
2007-02-20 18:18 EST, Nathan Kinder
no flags Details | Diff
Additional fix (638 bytes, patch)
2007-02-22 14:34 EST, Nathan Kinder
no flags Details | Diff

  None (edit)
Description Nathan Kinder 2007-02-20 18:18:19 EST
While testing the binaries from the autotools based build on HP-UX, I was unable
to get ns-slapd to run due to an unresolved symbol.  I was seeing the following
errors in the errors log:

error:[20/Feb/2007:10:31:55 -0800] - Netscape Portable Runtime error -5977:
Unsatisfied data symbol '_ZTVN10__cxxabiv120__si_class_type_infoE' in load
module '//opt/fedora-ds/lib/libicui18n.so.34'.

On HP-UX, the program that contains the main() function must be linked with the
C++ compiler (aCC -AA in our case) if it loads any C++ shared libraries.  The
fix is to tell libtool to use the C++ compiler to link ns-slapd.
Comment 1 Nathan Kinder 2007-02-20 18:18:19 EST
Created attachment 148457 [details]
Proposed Fix
Comment 2 Nathan Kinder 2007-02-21 12:46:55 EST
Checked into ldapserver (HEAD).  Thanks to Rich for the review!

Checking in Makefile.am;
/cvs/dirsec/ldapserver/Makefile.am,v  <--  Makefile.am
new revision: 1.28; previous revision: 1.27
done
Checking in Makefile.in;
/cvs/dirsec/ldapserver/Makefile.in,v  <--  Makefile.in
new revision: 1.32; previous revision: 1.31
done
Checking in ltmain.sh;
/cvs/dirsec/ldapserver/ltmain.sh,v  <--  ltmain.sh
new revision: 1.11; previous revision: 1.10
done
Comment 3 Nathan Kinder 2007-02-22 14:34:08 EST
Created attachment 148612 [details]
Additional fix

AN additional change is needed to allow ns-slapd to be linked on non HP-UX
systems.  It turns out that you need to explicitly set ns_slapd_LINK for all
cases .  By even attempting to override the implicit setting one only one
platform, ns_slapd_LINK will not be implicitly defined at all.
Comment 4 Nathan Kinder 2007-02-22 14:35:47 EST
Checked additional fix from comment #3 into ldapserver (HEAD).  The fix was
actually written by Rich, and reviewed and tested by myself and Noriko.

Checking in Makefile.am;
/cvs/dirsec/ldapserver/Makefile.am,v  <--  Makefile.am
new revision: 1.29; previous revision: 1.28
done
Checking in Makefile.in;
/cvs/dirsec/ldapserver/Makefile.in,v  <--  Makefile.in
new revision: 1.33; previous revision: 1.32
done

Note You need to log in before you can comment on or make changes to this bug.