Bug 229458 - firefox hangs system when opening gif image
firefox hangs system when opening gif image
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-21 05:11 EST by ritz
Modified: 2008-07-21 03:59 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-16 09:20:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ritz 2007-02-21 05:11:17 EST
Description of problem:
Open a gif image hangs the system. Opera does not.

Version-Release number of selected component (if applicable):
firefox-2.0.0.1-5.fc7

How reproducible:
always

Steps to Reproduce:
1. Open
http://cfa-www.harvard.edu/iau/Animations/EarthRide.gif
  
Actual results:
firefox causes disk thrashing 

Expected results:
firefox should not cause disk thrashing, or atleast warn that it will blow up
the system if it continues with the images.

Additional info:
Comment 1 ritz 2007-04-10 17:22:54 EDT
did i mention, i have zero swap on system, and this still causes disk thrasing :(
Comment 2 Martin Stransky 2007-04-12 09:34:20 EDT
It affects all programs what uses gif (eog, display...) so it isn't a firefox
issue. Reassigned to giflib (I hope the right component)
Comment 3 Norm Murray 2007-04-12 21:19:16 EDT
376 frames at 961x961 pixels... largely solid black... that compresses quite
well in the gif format. For amusement it takes a 2.7GB memory footprint to run
'display' against this gif, but it does work.

Predicting how large something will be when uncompressed is not possible. 

Unless you can provide a convincing case, I'll close this as notabug. 
Comment 4 Toshio Kuratomi 2007-04-13 00:35:36 EDT
For the (In reply to comment #2)
> It affects all programs what uses gif (eog, display...) so it isn't a firefox
> issue. Reassigned to giflib (I hope the right component)

A bit beside the point but none of those programs use giflib to render gif files.
Comment 5 ritz 2007-04-13 02:42:08 EDT
opera loads, and displays this image.
just curious, why not giflib applications ?

and my system has 1gig ram, with zero swap. If i understand correctly, disk
thrashing is a issue with kernel ?
Comment 6 Norm Murray 2007-04-13 03:01:19 EDT
firefox also doesn't seem to require giflib at all:
[root@s ~]# rpm -qR firefox | grep -i gif
[root@s ~]# 

You have a 1GB system and you're trying to use a data file which has a memory
footprint of 2.7Gb... that will definitely crush your vm into itsy pieces. 

Now... Opera may be attempting to deal with only one frame of the gif at a time
(which will mean it has to recompute every cycle through) rather than rendering
all frames into memory (saving time subsequent times through the animation).

Such large, deep animations are more likely the exception, so I'd venture the
path taken by ImageMagick (display) and firefox is the more valid. 

Anyhow, assigning back to firefox and Martin as this isn't a problem with either
giflib or ImageMagick gif handling. 
Comment 7 Martin Stransky 2007-04-13 04:37:21 EDT
okay. wontfix for now. If you care you can report it to mozilla.org
(https://bugzilla.mozilla.org/)
Comment 8 ritz 2007-04-13 06:27:14 EDT
sorry to ping again, to me the bug disk thrashes despite zero swap space.

As said by Norm, should this not be a kernel vm issue ?
The kernel should kill the offending process , which takes more than an hour.
Comment 9 Norm Murray 2007-04-15 19:59:38 EDT
Your disk 'thrashing' may just be writing to temporary files - remember 2.7GB
uncompressed. 

Comment 10 ritz 2007-04-16 03:36:12 EDT
my system goes down immediatly on opening this file.
1gig + laptop hard-disk combination.

would someone verify , if this is due to a temporary file, or otherwise ?
Comment 11 Martin Stransky 2007-05-16 09:20:16 EDT
Feel free to investigate this isse. Please reopen if you find out where the
problem is, but firefox has many more important issues.
Comment 12 ritz 2008-07-21 03:59:31 EDT
fixed with ff3.

Note You need to log in before you can comment on or make changes to this bug.