Bug 229480 - dom0: panic w/X on i965 (appears to be agpgart?)
dom0: panic w/X on i965 (appears to be agpgart?)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel-xen (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Eduardo Habkost
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-21 08:41 EST by Davide Bolcioni
Modified: 2009-12-14 15:37 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-26 18:56:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Davide Bolcioni 2007-02-21 08:41:01 EST
+++ This bug was initially created as a clone of Bug #214635 +++

Description of problem:

Usage of X on i965 under dom0 often panics the kernel, leading to a fault that
spontaneously reboots the machine.

Operations that can cause this:

1) starting X (has happened in gdm)
Comment 1 Davide Bolcioni 2007-02-21 08:45:07 EST
In my case, the problem manifests with display corruption of the lower half of 
the X display and a garbled cursor (running KDE) but the host is apparently 
functional as I am writing this (kernel-xen-2.6.19-1.2911.fc6).

According to Intel documentation, the i965 family uses system memory for the 
graphics adapter so, since this host has 4 GB, I tried booting with mem=3G 
like this:

title Fedora Core (2.6.19-1.2911.fc6xen)
        root (hd0,0)
        kernel /xen.gz-2.6.19-1.2911.fc6
        module /vmlinuz-2.6.19-1.2911.fc6xen ro root=/dev/sys_vg/root_lv 
all-generic-ide quiet mem=3G
        module /initrd-2.6.19-1.2911.fc6xen.img

which apparently fixed the display corruption problem.
Comment 2 Davide Bolcioni 2007-02-21 08:48:59 EST
Typing in a terminal and running glxgears apparently worked OK also using said 
workaround.
Comment 3 Davide Bolcioni 2007-02-22 12:03:37 EST
However, attempts to create a new fully virtualized Xen image consistently 
produce display corruption and lock up the host.
Comment 5 Red Hat Bugzilla 2007-07-24 21:38:27 EDT
change QA contact
Comment 7 Chris Lalancette 2008-02-26 18:56:04 EST
This report targets FC6, which is now end-of-life.

Please re-test against Fedora 7 or later, and if the issue persists, open a new bug.

Thanks

Note You need to log in before you can comment on or make changes to this bug.