Bug 22953 - dig/nslookup don't seem to use resolv.conf properly
dig/nslookup don't seem to use resolv.conf properly
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: bind (Show other bugs)
7.1
i386 Linux
low Severity low
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Need Real Name
Florence Gold
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-28 12:29 EST by Wade Minter
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-26 09:36:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Wade Minter 2000-12-28 12:29:48 EST
My /etc/resolv.conf is set up as so:

[minter@squirtle minter]$ cat /etc/resolv.conf 
search raleigh.netraverse.com netraverse.com
nameserver 216.5.103.195
[minter@squirtle minter]$ 

I'm trying to do a dig on host "zephyr.raleigh.netraverse.com".  Running
"dig zephyr" gives:

[minter@squirtle minter]$ dig zephyr

; <<>> DiG 9.1.0b1 <<>> zephyr
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 32164
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;zephyr.                                IN      A

;; AUTHORITY SECTION:
.                       9781    IN      SOA     A.ROOT-SERVERS.NET.
hostmaster.nsiregistry.NET. 2000122701 1800 900 604800 86400

;; Query time: 11 msec
;; SERVER: 216.5.103.195#53(216.5.103.195)
;; WHEN: Thu Dec 28 12:32:42 2000
;; MSG SIZE  rcvd: 100


Running "dig zephyr.raleigh.netraverse.com" gives:
[minter@squirtle minter]$ dig zephyr.raleigh.netraverse.com

; <<>> DiG 9.1.0b1 <<>> zephyr.raleigh.netraverse.com
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 27929
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 3, ADDITIONAL: 3

;; QUESTION SECTION:
;zephyr.raleigh.netraverse.com. IN      A

;; ANSWER SECTION:
zephyr.raleigh.netraverse.com. 432000 IN A      216.5.103.194

;; AUTHORITY SECTION:
raleigh.netraverse.com. 432000  IN      NS      ns1.netraverse.com.
raleigh.netraverse.com. 432000  IN      NS      ns2.netraverse.com.
raleigh.netraverse.com. 432000  IN      NS      ns3.netraverse.com.

;; ADDITIONAL SECTION:
ns1.netraverse.com.     432000  IN      A       216.5.96.90
ns2.netraverse.com.     432000  IN      A       216.5.96.85
ns3.netraverse.com.     432000  IN      A       216.5.103.195

;; Query time: 13 msec
;; SERVER: 216.5.103.195#53(216.5.103.195)
;; WHEN: Thu Dec 28 12:33:30 2000
;; MSG SIZE  rcvd: 187

nslookup does the same type thing.  It appears that dig/nslookup aren't
using the search path from resolv.conf.
Comment 1 Daniel Roesen 2000-12-29 07:33:06 EST
dig is not supposed to append domains out of /etc/resolv.conf, but nslookup is.
Comment 2 Bernhard Rosenkraenzer 2001-01-10 18:13:16 EST
Still present in 0.b3.1
Comment 3 Glen Foster 2001-01-11 16:06:05 EST
This defect is considered MUST-FIX for Florence Gold release
Comment 4 Karsten Hopp 2001-01-26 08:49:59 EST
I failed to reproduce this problem with bind-utils-9.1.0-2. 
nslookup and host use the search entry in /resolv.conf and the 
domain part of the hostname.
dig isn't supposed to use the search entry in resolv.conf, it uses only
the DNS information from that file.
I suggest to close this report as 'not a bug'
Comment 5 Wade Minter 2001-01-26 09:36:27 EST
Confirmed to be working with bind-utils-9.1.0-1.

Note You need to log in before you can comment on or make changes to this bug.