Bug 22954 - update to broken up2date does not work
update to broken up2date does not work
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
Aaron Brown
http://www.redhat.com/support/errata/...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-28 12:35 EST by Need Real Name
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-28 12:35:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-12-28 12:35:06 EST
I've downloaded RPM's and followed the instruction in RHBA-2000:138-03

I get the following error messagers:

[root@msd deiss]# rpm -Uvh up2date-2.1.7-1.i386.rpm
error: failed dependencies:
	up2date = 2.0.6 is needed by up2date-gnome-2.0.6-1
[root@msd deiss]# rpm -Uvh up2date-gnome-2.1.7-1.i386.rpm
error: failed dependencies:
	up2date = 2.1.7 is needed by up2date-gnome-2.1.7-1
[root@msd deiss]# rpm -Uvh python-xmlrpc-1.2.1-1.i386.rpm
package python-xmlrpc-1.2.1-1 is already installed

Apparently, two of the three packages failed to install properly.  I don't
know where to get and how to install up2date 2.06 and up2date-gnome-2.17. 
I've looked around on your FTP site and can't find it.

The reason why I'm installing the upgrade to up2date is that it crashes
with script error messages.  I think a lot more work is needed on up2date.
Comment 1 Pekka Savola 2000-12-28 17:49:59 EST
Use:

rpm -Uvh up2date-2.1.7-1.i386.rpm up2date-gnome-2.1.7-1.i386.rpm

ie. these must on the same line if there are so called circular dependencies.

Note You need to log in before you can comment on or make changes to this bug.