Bug 229607 - Rawhide kernel fails to boot on Macbook Pro
Rawhide kernel fails to boot on Macbook Pro
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks: FC7Blocker
  Show dependency treegraph
 
Reported: 2007-02-21 20:30 EST by David Zeuthen
Modified: 2013-03-05 22:49 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-15 15:41:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the backtrace (1.31 MB, image/jpeg)
2007-02-21 20:30 EST, David Zeuthen
no flags Details
another backtrace (88.42 KB, image/png)
2007-03-07 11:14 EST, Rafael Ávila de Espíndola
no flags Details

  None (edit)
Description David Zeuthen 2007-02-21 20:30:23 EST
Description of problem:

kernel panic (I think) on bootup. Will attach picture from my digicam.

Version-Release number of selected component (if applicable):

kernel-2.6.20-1.2936.fc7

How reproducible:

Always. Tried booting five times.

Steps to Reproduce:

This is on a Macbook Pro with a Core Duo (not Core2; it's 1st generation Macbook
Pro).
Comment 1 David Zeuthen 2007-02-21 20:30:24 EST
Created attachment 148555 [details]
the backtrace
Comment 2 Andrew Cathrow 2007-02-22 08:27:04 EST
Just reproduced the same on a MacBook with core-2-duo.
Tried this on 2936 and 2911 with same result. Last kernel that I have that
appears to work is 2.6.20-1-2898.2.3.fc7

Unable to get a trace other than taking a photo, and David's trace is identical
to mine.

This happens immediately after

PCI: Using MMCONFIG
Setting up standard PCI resources

I've tried pci=nommconf incase that's the issue and various combinations of pci=
but I'm still unable to boot
Comment 3 Ruben Kerkhof 2007-02-24 14:59:55 EST
I can confirm this on my Macbook Pro first generation as well.
Comment 4 David Zeuthen 2007-03-03 15:03:32 EST
Still happening with .2962...
Comment 5 Rafael Ávila de Espíndola 2007-03-04 22:18:47 EST
compiling without CONFIG_DEBUG_MUTEXES "solves" the problem. The problem is also
present on linus git tree.
Comment 6 Rafael Ávila de Espíndola 2007-03-07 01:21:59 EST
I tried to us netconsole to get a better trace, but the kernel crashes before
the netconsole is up :-(
I want to help, but I think that I will need some information on how to debug this.
Comment 7 Rafael Ávila de Espíndola 2007-03-07 11:14:05 EST
Created attachment 149461 [details]
another backtrace
Comment 8 Rafael Ávila de Espíndola 2007-03-14 01:11:58 EDT
Fixed on 2985
Comment 9 Will Woods 2007-03-15 15:18:50 EDT
davidz, can you confirm that this problem is fixed in kernel .2985 and later?
Comment 10 David Zeuthen 2007-03-15 15:41:50 EDT
Yeah, latest Rawhide boots. Thanks. Closing this bug.

Note You need to log in before you can comment on or make changes to this bug.