Bug 22962 - RFE: make 'Assigned To:' field on bug forms a drop-down
RFE: make 'Assigned To:' field on bug forms a drop-down
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
2.8
i386 Linux
low Severity medium (vote)
: ---
: ---
Assigned To: David Lawrence
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-28 17:16 EST by Brian Richardson
Modified: 2007-03-26 23:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-06 01:45:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Richardson 2000-12-28 17:16:33 EST
Instead of a blank field, make 'Assigned To:' a select box with list of all
current user IDs (assuming Bugzilla user has rights to change bug
information). This would prevent bad e-mail addresses from being entered in
this field.

(Note: I am working on this. If I get it working, I'll send the code.)
Comment 1 David Lawrence 2000-12-28 17:32:04 EST
I assume you are talking about the "Assign bug to [ ]" box in the Change state
or resolution box. That  would normally be a good idea and would not be hard at
all to implement, it is just that our Bugzilla currently has almost 25000
members and would not fit very well into a drop down box. I could sort the list
by particular groups that the people belong to such as only display people who
are members of 'qa' or 'devel' groups but you would still need to have the
regular text box available for addition of people who are not in those. This
would add more to the already large amount of clutter on the bug form. I would
be glad to look at whatever you come up with.
Comment 2 Brian Richardson 2000-12-28 17:40:30 EST
The database I'm using will be smaller by a few orders of magnitude, but I
understand the problem of making a 25,000 element scroll box. Perhaps some sort
of secondary window would be better, allowing a search feature by name (kind of
like the dialog for editmembers.cgi).
Comment 3 Aleksey Nogin 2003-01-06 01:10:38 EST
Bugzilla 2.17 allows email wilcards and email completion (enabled by a
"usermatchmode" configuration parameter). When both are enabled, one can put
"*@redhat.com" or "dkl" into any email field (CC, Assigned To, etc). When there
is only one match, Bugzilla will just use it and when there are several matches
(up to "maxusermatches" matches) Bugzilla will give a drop-down box with all of
them.

P.S. David, do you think this would be worth enabling in this Bugzilla?
Comment 4 David Lawrence 2003-01-06 01:45:25 EST
Okay I have enabled this new feature and it seems to work real well, *sigh* one
more thing I need to document. This definitely keeps the drop down list more
managable since it doesnt limit it to only redhat.com addresses like some
implementations. Please reopen if this is not satisfactory to the reporter of
this bug.

Note You need to log in before you can comment on or make changes to this bug.