Bug 229654 - USB 2.0 transfer size limit problem: Vuescan does not recognize scanner
USB 2.0 transfer size limit problem: Vuescan does not recognize scanner
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-22 10:13 EST by williamnorfleet2000
Modified: 2008-04-04 07:35 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-04 07:35:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description williamnorfleet2000 2007-02-22 10:13:21 EST
Description of problem:
Vuescan 8.3.87 does not recognize a Minolta Scan Dual III scanner on a desktop
machine with a fresh install of FC5 updated via yum. An exchange of emails with
the developer of Vuescan concludes: "This would indicate a kernel problem . . .,
probably in the USB subsystem limiting transfers to 32 KBytes." "The problem is
that when VueScan tries to load the firmware into the scanner, it tries to
transfer 44904 bytes in a single transfer. This is failing."  Connecting the
scanner to the motherboard's USB 1.0 port results in proper function of the Dual
III, so the problem seems to be confined to USB 2.0.  So far I have not been
able to identify where this transfer limit is established - via an option passed
to a kernel module or within a module itself.  


Version-Release number of selected component (if applicable):
kernel 2.6.18-1.2257.fc5

How reproducible:
Every try.

Steps to Reproduce:
1. delete ~/.vuescan
2. shut down and remove power from scanner and computer; plug scanner into USB
2.0 port
3. boot computer
4. turn on scanner
5. run vuescan:  observe that vuescan properly identifies the scanner as a Dual
III, but that the scanner responds to no vuescan commands such as "Calibrate" or
"Scan".
  
Actual results:
Scanner responds to no vuescan commands such as "Calibrate" or "Scan"

Expected results:
Scanner calibaration or scan activity in response to these commands.

Additional info:
Comment 1 Pete Zaitcev 2007-02-22 14:04:37 EST
32KB sounds like a limit on the single URB size as enforced by usbfs.
But if so, it would affect both speeds. Something does not compute
about this report.

What's the e-mail of the Vuescan guy?
Comment 2 williamnorfleet2000 2007-02-22 14:53:56 EST
EdHamrick@aol.com
Comment 3 williamnorfleet2000 2007-02-26 18:29:55 EST
Downloaded the latest version of Vuescan (8.4.12).  Same problem:  Vuescan works
through the USB 1.0 port, but fails through the USB 2.0 port.  Now running
kernel 2.6.19-1.2288.fc5
Comment 4 williamnorfleet2000 2007-02-27 15:13:39 EST
Tried a different computer:  Vuescan works with the Minolta Scan Dual III
scanner when connected to a Zonet ZUN2200 USB 2.0 Cardbus PC Card on a Thinkpad
600E also running Vuescan 8.4.12 and kernel 2.6.19-1.2288.fc5.  Perhaps this bug
is card-specific?  The non-working card is a "CTG USB 2.0 Hi-Speed 5-Port PCI
Card", Tiger Direct Item No. C184-29554, purchased in November, 2006.  This card
works well with a variety of devices including an Epson Perfection 1260 flat-bed
scanner being driven by Vuescan 8.4.12 - the Minolta Scan Dual III is the only
device tried so far that has not worked with it.  
Comment 5 williamnorfleet2000 2007-03-28 10:19:06 EDT
This problem persists under kernel 2.6.20-1.2307.fc5
Comment 6 williamnorfleet2000 2007-03-31 21:22:20 EDT
This problem is "fixed" by:  rmmod ehci_hcd
Comment 7 williamnorfleet2000 2007-07-05 20:33:08 EDT
The problem seems to be card-specific.  The card in question is a "Cables To Go
USB 2.0 Hi-Speed 5-Port PCI Card", item number C184-29554 at Tiger Direct. 
Replacing this card with an "IOFuture PU520 High-Speed USB 2.0 PCI Host
Controller", item number 15-104-216 at NewEgg, caused this and some other
strange USB-related problems to go away.
Comment 8 Bug Zapper 2008-04-04 02:19:57 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.