This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 229667 - kdm + pam + selinux = asking for password, but denying access
kdm + pam + selinux = asking for password, but denying access
Status: CLOSED DUPLICATE of bug 229039
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-22 11:42 EST by Alexei Podtelezhnikov
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-22 12:51:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexei Podtelezhnikov 2007-02-22 11:42:09 EST
Description of problem:
This is FC6 with all updates. When I use kdm by adding DISPLAYMANAGER="KDE"
to /etc/sysconfig/desktop, I cannot run pup/pirut as a regular user anymore.
This is what is in dmesg:

: exe="/bin/dbus-daemon" (sauid=81, hostname=?, addr=?, terminal=?)'
audit(1172161508.578:11): avc:  denied  { transition } for  pid=5201 
comm="userhelper" name="pup" dev=dm-0 ino=1922908 
scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 
tcontext=system_u:system_r:rpm_t:s0 tclass=process

Version-Release number of selected component (if applicable):
kdebase-3.5.6-0.1.fc6
selinux-policy-2.4.6-40.fc6
pam-0.99.6.2-3.15.fc6


How reproducible: 100%


Steps to Reproduce:
1. add DISPLAYMANAGER="KDE" to /etc/sysconfig/desktop
2. cycle through 'init 3' and 'init 5' to switch to kdm 
3. Login as a user and try 'pup'. It'll ask for a password, but no more 
4. go back to gdm, and everything is fine
  
Additional info:
I don't know if it's selinux or kdm fault, so ccing Than and assigning to 
Daniel.
Comment 1 Daniel Walsh 2007-02-22 12:51:08 EST
This is a pam problem.

*** This bug has been marked as a duplicate of 229039 ***

Note You need to log in before you can comment on or make changes to this bug.