Bug 229670 - anaconda does not bring up loopback device during install
anaconda does not bring up loopback device during install
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-22 12:15 EST by Orion Poplawski
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-06 15:54:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2007-02-22 12:15:31 EST
Doing a PXE/kickstart/NFS install of rawhide from 20070222.  The loopback device
is not configured.  This prevents me from mounting an nfs directory in %post
because the mount.nfs command tries to contact the local portmap server via the
loopback address.
Comment 1 Chris Lumens 2007-02-22 12:33:08 EST
David - looks like lo is configured, but not brought up.  Similar to other
issues we've had with regular interfaces.

Orion - for now you should be able to work around this with a quick "ifconfig lo
up" at the beginning of your %post script.
Comment 2 David Cantrell 2007-03-06 15:54:05 EST
Yeah, the netlink API is not friendly past kernel 2.6.17.  Rewrote
initLoopback() to use ioctl() and it's working now.

Note You need to log in before you can comment on or make changes to this bug.