Bug 229769 - Pirut exception during software update
Pirut exception during software update
Status: CLOSED DUPLICATE of bug 229663
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
6
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-23 07:18 EST by Bernhard Fastenrath
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-23 11:02:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Exception dump (1.37 KB, text/plain)
2007-02-23 07:18 EST, Bernhard Fastenrath
no flags Details
Crash Dump from Exception (1.37 KB, text/plain)
2007-02-23 10:25 EST, William Makowski
no flags Details

  None (edit)
Description Bernhard Fastenrath 2007-02-23 07:18:08 EST
Description of problem:
The package updater threw an exception and couldn't be restarted without reboot,
claiming another application was accessing the software database.
The exception summary was: TBccefa5c9 yumRepo.py:426:__get:RepoError: failure:
repodata/updateinfo.xml.gz from updates: [Errno 256] No more mirrors to try.

Version-Release number of selected component (if applicable):
Name        : pirut                        Relocations: (not relocatable)
Version     : 1.2.8                       Vendor: Red Hat, Inc.
Release     : 1.fc6                       Build Date: Fri 10 Nov 2006 05:16:51 

How reproducible:
software update

Steps to Reproduce:
1. Select "View Updates..." from the notification area.
2. Select "Apply Updates" from the software updater.
  
Actual results:
Exception

Expected results:
Software update

Additional info:
The exception indicates a problem with mirror servers. I couldn't find any
configuration for pirut that selects a preferred mirror server but just in case
it does - I used ftp://ftp.uni-koeln.de/redhat/linux/6.0/en/os/i386/ or 
ftp://ftp.stw-bonn.de/pub/fedora/linux/core/6/i386/ to install the system.
Comment 1 Bernhard Fastenrath 2007-02-23 07:18:08 EST
Created attachment 148659 [details]
Exception dump
Comment 2 William Makowski 2007-02-23 10:25:11 EST
Created attachment 148671 [details]
Crash Dump from Exception

I had the same exception occur and have attached the crash dump I received. 
When the Updates Available message pops up it indicates there are 4 updates
available.  

_Steps_to_Reproduce_
1) Click on View Updates
2) Enter Root Password
3) App sits for about 4-5 minutes at Retrieving update information and then
produces the exception.

I also tried running the Software Updater separately from the menu with the
same results.

If I run yum update at the command line it shows 6 updates available (see
below).  It looks like I could run this through to completion, but wanted to
wait and report the exception.

Updating:
 libswt3-gtk2		 i386	    1:3.2.2-1.fc6    updates	       3.4 M
 pam			 i386	    0.99.6.2-3.16.fc6  updates		 924 k
 pam-devel		 i386	    0.99.6.2-3.16.fc6  updates		 187 k
 slang			 i386	    2.0.7-1.fc6      updates	       328 k
 slang-devel		 i386	    2.0.7-1.fc6      updates	       539 k
 slrn			 i386	    0.9.8.1pl1-2.fc6  updates		806 k
Comment 3 Jeremy Katz 2007-02-23 11:02:54 EST

*** This bug has been marked as a duplicate of 229663 ***

Note You need to log in before you can comment on or make changes to this bug.