Bug 229793 - beryl-plugins depends on fedora-logos
beryl-plugins depends on fedora-logos
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: beryl-plugins (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jarod Wilson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-23 10:24 EST by Matthew Booth
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-23 16:12:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Booth 2007-02-23 10:24:48 EST
Description of problem:
beryl-plugins depends on fedora-logos, which makes it uninstallable on RHEL5
without recompilation. I haven't looked closely into the fedora-logos
requirement, however such a simple thing doesn't seem like a good enough reason
for incompatibility. fedora-logos conflicts with redhat-logos.

Version-Release number of selected component (if applicable):
0.1.9999.2-1.fc6
RHEL5 RC1
Comment 1 Jarod Wilson 2007-02-23 11:52:38 EST
Graphics from fedora-logos are used to brand the top and bottom of the cube
desktop switcher, and regardless, a package built for Fedora not installing on
RHEL5 actually seems quite sane to me. :) If you'd like beryl for RHEL5, you
could submit a request for an EL-5 branch in CVS and it could be done under the
EPEL banner, complete with a req on redhat-logos instead, RHEL branding, etc.
I've purposely not requested an EL-5 branch to date though, because I really
don't feel this stuff is really enterprise-ready...

http://fedoraproject.org/wiki/EPEL/WishList
Comment 2 Matthew Booth 2007-02-23 15:52:05 EST
I don't want to submit beryl for EPEL. I have it installed (manual recompile),
and it regularly eats my desktop. It's a nice toy which I like to show to people
who like that sort of thing.

The RPM philosophy is ideally reasonably distribution neutral. If all
dependencies are correct and everything is sane, I expect something to either:

* Install correctly and work
* Not install in the first place

I use a number of FC packages on my box, and they work just fine. When glibc or
gtk+ get upgraded I expect things to get a little hairier. A dependency failure
due to different graphics just seems a bit obnoxious and unnecessary. I note the
following:

[mbooth@mbooth ~]$ rpm -q --qf "[%{PROVIDES}\n]" redhat-logos
system-logos
redhat-logos

Could the dependency be changed to either:

* "system-logos", assuming fedora-logos also provides this
* The names of specific files which are used

That way the package will interoperate nicely with RHEL without recompilation.
Comment 3 Jarod Wilson 2007-02-23 16:12:22 EST
I realize plenty of FC6 packages work on RHEL5 today, but yeah, that can get
rather hairy down the road...

That said, I could change the Req: to system-logos, or I could just drop that
dependency altogether, since the package actually uses a piece of artwork from
fedora-logos, but includes the specific artwork as Source1. Which reminds me,
that needs to be updated for rawhide.

New build w/o any logos dep forthcoming.

Note You need to log in before you can comment on or make changes to this bug.