Bug 22983 - rpm --rebuilddb no longer removes duplicates
rpm --rebuilddb no longer removes duplicates
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-29 10:29 EST by Frank Ch. Eigler
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-29 10:29:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Ch. Eigler 2000-12-29 10:29:31 EST
When, somehow, the same RPM is installed twice, "rpm -qa" shows two
identical instances.  "rpm --rebuilddb" in the recent past was able
to eliminate one of the duplicate database entries; rpm-4.0-4 no
longer seems to be able to.  This leaves as the only recovery method
the complete uninstallation of the program ("rpm -e --allmatches")
followed by a reinstallation.

It may help to know that the host displaying this problem is "up2date"
with all glibc/rpm/etc. patches as of 2000-12-25 or so.
Comment 1 Jeff Johnson 2000-12-29 11:01:21 EST
Um, removing duplicates during --rebuilddb was never "supported" functionality,
only
a dirty hack to work around a buggy development rpm that leaked through Raw
Hide.
In fact, rpm is designed to be perfectly happy with multiple instances of the
same package
installed (and in the database).

Add --define '_filterdbdups 1' if you must, or (equivalently)
	mkdir -p /etc/rpm
	echo "%_filterdbdups 1" >> /etc/rpm/macros
but I suggest that you really need to look at how the duplicates are getting in
the database
in the 1st place, as that's where the real problem is.

Note You need to log in before you can comment on or make changes to this bug.