Bug 229836 - Requiring gender-neutral greeting for user
Requiring gender-neutral greeting for user
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
511
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Lestach
Jiří Mikulka
: Reopened, Triaged
Depends On:
Blocks: sat550-lowbug
  Show dependency treegraph
 
Reported: 2007-02-23 13:42 EST by Máirín Duffy
Modified: 2014-10-06 09:46 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-21 05:34:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Máirín Duffy 2007-02-23 13:42:49 EST
Description of problem:
Sat & Hosted

When a system administrator creates a sub-account under their org using the
Users UI in RHN, they need to choose from a selection of gender-specific
greetings. The sysadmin might not actually know the person in question and may
not be sure of the user's gender (or preferred gender).

Just a small suggestion here to add a N/A option to the 'greetings' drop down
when creating new user accounts. 

Also a note that 'Hr.' and 'Sr.' are inexplicably in the list of greetings. This
is also the case for www in prod. Are these gender neutral? If not, we should
consider either adding the analogous female greetings, or taking them out
entirely and allowing localization to handle the available greetings.

If there are SSO-dependencies/etc relating to this bug in hosted, let me know
and I can file it under SSO as well.
Comment 6 Miroslav Suchý 2011-09-16 10:26:18 EDT
Sr. is not gender specific (according to wikipedia) and Hr. is abbreviation of Herr. There is gender related Ms. which in German localization is translated to Fr. as Fraulin.
So I would say we are gender correct. The only guestion is whether to remove Hr. or not as it is duplicate of Mr.
But the removal is much harded (you must migrate existing data of customers) then to add something and IMO not worht the work.
Comment 7 John T. Rose 2011-09-16 11:13:26 EDT
The real life situation that comes up is a request for an account comes in from someone, say for example named Pat Brown. The admin does not know if Pat is a male or a female. Do you really think Sr. is appropriate?

The situation is worse with names which do reveal gender but which aren't familiar to the admin in which case bad guesses on the admin's part can be considered offensive to the person requesting the account. Imagine a English only speaking admin seeing 50 different Chinese names with which he/she is unfamiliar.

In either of these cases what should the admin do? Take a gender specific guess and be wrong and offend users on occasion? Ask the user what their sex is before creating the account? (That would go over real well here.)

Please reconsider as this has caused us problems for years and all we need is something that would be appropriate and gender neutral for cases where the gender of the user is unknown.
Comment 8 Miroslav Suchý 2011-09-16 11:51:34 EDT
Gender neutral? So you basicaly ask for empty field? - since currently you have to choose something.
Comment 9 John T. Rose 2011-09-16 12:17:07 EDT
An empty field would be just fine. Having to basically guess either Mr. or Ms. and sometimes getting that wrong offends some people and embarrasses others and the field doesn't really seem very important to begin with.
Comment 10 Miroslav Suchý 2011-09-19 03:28:09 EDT
That sounds as plan. Reopening.
Comment 11 Miroslav Suchý 2011-10-03 05:40:42 EDT
commited to spacewalk.git as e8e83e3190072ca434bc02fae06d04db84b54f0d
Comment 14 Clifford Perry 2012-09-21 05:34:05 EDT
This issue is resolved with the release of RHN Satellite 5.5. 

As of September 20th 2012, RHN Satellite 5.5 has been generally available. 

Release Notes and other 5.5 documentation can be found here:

 https://access.redhat.com/knowledge/docs/Red_Hat_Network_Satellite/

The associated Errata for the 5.5 release are:

5.5 Satellite GA Errata
 - http://rhn.redhat.com/errata/RHEA-2012-1296.html

5.5 Upgrade Errata
 - http://rhn.redhat.com/errata/RHEA-2012-1298.html

5.5 RHN Proxy GA Errata
 - http://rhn.redhat.com/errata/RHEA-2012-1297.html

5.5 RHN Tools GA Errata
 - http://rhn.redhat.com/errata/RHEA-2012-1299.html

Regards,
Clifford
- Engineering Manager, Satellite

Note You need to log in before you can comment on or make changes to this bug.