Bug 22984 - up2date install fails if multiple versions of updateable RPMs already installed
Summary: up2date install fails if multiple versions of updateable RPMs already installed
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
: 28536 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-29 15:38 UTC by Frank Ch. Eigler
Modified: 2015-01-07 23:42 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-13 20:30:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2001:048 normal SHIPPED_LIVE New Update Agent with many fixes and enhanced functionality available 2001-04-12 04:00:00 UTC

Description Frank Ch. Eigler 2000-12-29 15:38:21 UTC
If somehow multiple versions of a ordinary updateable RPMs are installed,
up2date 2.1.7-1 can fail to recognize that the most recent version is
already installed.  In other words, during the "Removing installed packages
from list of updates..." phase, up2date appears to notice that an earlier
version of RPM foo is there (and therefore in need of update), but not that
the later version is also there (and therefore no need to update).  Then
up2date fetches the duplicate newer-version RPM, and causes a failure
during installation.

up2date should be more tolerant of the possibility of multiple generations
of the same package being installed.

Comment 1 Aleksey Nogin 2001-01-03 21:21:20 UTC
I have the same problem with up2date-2.1.7-0.6.x on RedHat 6.2. In particular, I
have two versions of kernel-smp installed:
% rpm -q kernel-smp
kernel-smp-2.2.16-3
kernel-smp-2.2.14-12

and when I run up2date, it offers me to download kernel-smp-2.2.16-3

Comment 2 Andrew Bartlett 2001-01-04 10:21:49 UTC
Ditto here, I had 2.2.14 and 2.2.16 kernels installed, including sources.  This
also meant that it wanted to download over 100MB, both unnecercery and
time-consuming.  (And in some places, quite expencive).

To cap it off I never got the updates installed, as I also didn't have the space
either.

Comment 3 Preston Brown 2001-02-09 05:30:13 UTC
working on this.  thanks.

Comment 4 Cristian Gafton 2001-02-20 01:33:58 UTC
Assigned QA to jturner

Comment 5 Preston Brown 2001-03-01 17:44:36 UTC
*** Bug 28536 has been marked as a duplicate of this bug. ***

Comment 6 Preston Brown 2001-03-01 20:47:06 UTC
fixed in CVS.

Comment 7 Ryan Hill 2001-03-13 20:30:17 UTC
Also noticed the same problem today with a manual kernel upgrade in 7.0 from
2.2.16 to 2.2.17-14.  Both kernels are currently installed, but up2date is
apparently seeing only 2.2.16 and ignoring 2.2.17, even after up2date -p.

Comment 8 Preston Brown 2001-04-12 20:56:35 UTC
addressed in errata due out today.


Note You need to log in before you can comment on or make changes to this bug.