Bug 229862 - Errata counts for system groups are seemingly incorrect
Errata counts for system groups are seemingly incorrect
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
rhn500
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jesus M. Rodriguez
Preethi Thomas
:
Depends On:
Blocks: 166615
  Show dependency treegraph
 
Reported: 2007-02-23 15:45 EST by Máirín Duffy
Modified: 2007-04-18 14:00 EDT (History)
1 user (show)

See Also:
Fixed In Version: rhn500h
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-13 13:07:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot 1: see there are 7 systems in the group (88.27 KB, image/png)
2007-02-23 15:50 EST, Máirín Duffy
no flags Details
screenshot 2: see 17 affected systems for the xorg erratum (132.07 KB, image/png)
2007-02-23 16:04 EST, Máirín Duffy
no flags Details
screenshot 3: note that in the affected systems list, only 1 system is listed (82.91 KB, image/png)
2007-02-23 16:07 EST, Máirín Duffy
no flags Details
screenshot 4: note 454 systems org-wide are affected by the xorg erratum, meaning the '17' wasn't an org-wide count (114.42 KB, image/png)
2007-02-23 16:13 EST, Máirín Duffy
no flags Details

  None (edit)
Description Máirín Duffy 2007-02-23 15:45:46 EST
Description of problem:

- log in as qa@redhat.com in webqa.
- go to the systems > system groups page.
- see that updates are available for the 'Engineering Development Group'. also
note that there are *7* systems in this system group. click on the 'Engineering
Development Group'
- click on the 'more info' link after the updates available icon (see screenshot 1)
- look at list of applicable updates. see that '17' affected systems are listed
for the xorg errata (yes, 17. there are 7 systems in the group.) (See screenshot 2)
- click on the '17' link to go see which 17 systems are affected. note that
there is only one system, alpo, listed. 1 != 17. :) (see screenshot 3)
- go back a screen, and click on the xorg errata link. click on the affected
systems tab. note that 454 systems org-wide have this erratum applicable to them
(meaning that the 17 is not an org-wide number) (See screenshot 4)
Comment 1 Máirín Duffy 2007-02-23 15:50:12 EST
Created attachment 148714 [details]
screenshot 1: see there are 7 systems in the group
Comment 2 Máirín Duffy 2007-02-23 16:04:04 EST
Created attachment 148716 [details]
screenshot 2: see 17 affected systems for the xorg erratum
Comment 3 Máirín Duffy 2007-02-23 16:07:43 EST
Created attachment 148717 [details]
screenshot 3: note that in the affected systems list, only 1 system is listed
Comment 4 Máirín Duffy 2007-02-23 16:13:19 EST
Created attachment 148721 [details]
screenshot 4: note 454 systems org-wide are affected by the xorg erratum, meaning the '17' wasn't an org-wide count
Comment 5 Partha Aji 2007-02-27 01:26:43 EST
There are 2 issues in the listed bug

1)
- look at list of applicable updates. see that '17' affected systems are listed
for the xorg errata (yes, 17. there are 7 systems in the group.) (See screenshot 
This part has been resolved.. It should have shown 1 not 17 in the affected
systems count.


2)
- click on the '17' link to go see which 17 systems are affected. note that
there is only one system, alpo, listed. 1 != 17. :) (see screenshot 3)
- go back a screen, and click on the xorg errata link. click on the affected
systems tab. note that 454 systems org-wide have this erratum applicable to them
(meaning that the 17 is not an org-wide number) (See screenshot 4)


Ok this I believe works as expected... Here is the behavior seen...

When you click on the Affected Systems count on the list, you are considering
the relevant errata for the Systems in the selected SYSTEM GROUP.. i.e. you are
looking at the relevant errata for all the  systems on Engineering group..

However when you click on A errata and go through its details screen and then
hit Affected Systems, you are getting the data for ALL the systems (not just the
ones in the system group) that the user has access to, for whom the selected
errata is relevant...
Comment 6 Preethi Thomas 2007-03-01 15:17:38 EST
Looks like the first part has been fixed. And the 2nd part is as per designed.
So moving to verified.
Comment 7 Preethi Thomas 2007-03-08 12:53:11 EST
verified in stage
Comment 8 Brandon Perkins 2007-03-13 09:59:37 EDT
Closed in rhn500h Release.
Comment 9 Brandon Perkins 2007-03-13 13:07:51 EDT
Closed in rhn500h release.

Note You need to log in before you can comment on or make changes to this bug.