Bug 229868 - concurrent edits does not warn that the page is being edited, changes are overwritten
Summary: concurrent edits does not warn that the page is being edited, changes are ove...
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora Documentation
Classification: Fedora
Component: docs-requests (Show other bugs)
(Show other bugs)
Version: devel
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Dimitris Glezos
QA Contact: Karsten Wade
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-23 21:09 UTC by Karsten Wade
Modified: 2009-08-05 18:43 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-15 02:10:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Karsten Wade 2007-02-23 21:09:34 UTC
If a user is editing a page and another edits it, the second user is not warned.
 When the pages are finally saved, the collision is not alerted and one of the
user's changes are overwritten.

We tested with two users on this page:

http://fedoraproject.org/wiki/KarstenWade/TestOfEditBug

As described, our test followed this:

1. First user edited page, made changes
2. Second user edited page, was not warned page was being edited
3. First user saved changes
4. Second user saved changes, was not warned of a collision, and second user
changes overwrote first user changes

Comment 1 Karsten Wade 2007-02-23 21:10:23 UTC
Bumping severity up because this is pretty serious.

Comment 2 Paul W. Frields 2007-02-23 22:06:13 UTC
This bug apparently has to do with the theme.  Users can temporarily avoid the
problem by switching themes in their UserPreferences page.  Fix coming soon, it
sounds like...

Comment 3 Dimitris Glezos 2007-03-15 02:10:10 UTC
Fixed.

Comment 4 eric@christensenplace.us 2009-08-05 18:43:10 UTC
Tickets move to docs-request so the fedora-websites component can be removed per request from Ricky.


Note You need to log in before you can comment on or make changes to this bug.