Bug 230009 - ballbuster crashes software GLX
ballbuster crashes software GLX
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
6
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-25 14:52 EST by Tim McConnell
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-26 14:37:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf file (1.90 KB, text/plain)
2007-02-25 14:52 EST, Tim McConnell
no flags Details
previous settings (1.97 KB, text/plain)
2007-02-25 14:53 EST, Tim McConnell
no flags Details
for 3d (1.75 KB, text/plain)
2007-02-25 14:53 EST, Tim McConnell
no flags Details
dmesg file (20.14 KB, text/plain)
2007-02-25 14:55 EST, Tim McConnell
no flags Details
Xorg logs (50.67 KB, text/plain)
2007-02-25 14:56 EST, Tim McConnell
no flags Details
from switching to the nv to the nvidia drivers in system config display (19.26 KB, text/plain)
2007-02-25 14:57 EST, Tim McConnell
no flags Details
Xorg setup files (843 bytes, text/plain)
2007-02-25 14:58 EST, Tim McConnell
no flags Details
Shows default settings (620.46 KB, image/png)
2007-03-08 15:30 EST, Tim McConnell
no flags Details
Shows NVIDIA drivers selected (625.38 KB, image/png)
2007-03-08 15:31 EST, Tim McConnell
no flags Details

  None (edit)
Description Tim McConnell 2007-02-25 14:52:16 EST
Description of problem:
I have kernel version 2.6.19-1.2911.fc6xen #1 SMP Sat Feb 10 16:09:50 EST 2007
i686 athlon i386 GNU/Linux installed with the following Nvidia drivers:
kmod-nvidia-96xx-kdump-1.0.9631-4.2.6.19_1.2911.fc6
xorg-x11-drv-nvidia-96xx-devel-1.0.9631-5.lvn6
xorg-x11-drv-nvidia-96xx-1.0.9631-5.lvn6
kmod-nvidia-96xx-PAE-1.0.9631-4.2.6.19_1.2911.fc6
nvidia-96xx-kmod-debuginfo-1.0.9631-4.2.6.19_1.2911.fc6
kmod-nvidia-96xx-xen-1.0.9631-4.2.6.19_1.2895.fc6
kmod-nvidia-96xx-kdump-1.0.9631-4.2.6.19_1.2895.fc6
kmod-nvidia-96xx-1.0.9631-4.2.6.19_1.2911.fc6
kmod-nvidia-96xx-1.0.9631-4.2.6.19_1.2895.fc6
kmod-nvidia-96xx-xen-1.0.9631-4.2.6.19_1.2911.fc6
The actual card is a Nivida GForce2 200 MX.
running the command 'kudzu -p -c VIDEO' results:
class: VIDEO
bus: PCI
detached: 0
driver: nvidiafb
desc: "nVidia Corporation NV11DDR [GeForce2 MX 100 DDR/200 DDR]"
video.xdriver: nv
vendorId: 10de
deviceId: 0111
subVendorId: 0000
subDeviceId: 0000
pciType: 1
pcidom:    0
pcibus:  1
pcidev:  0
pcifn:  0
The problem is when I try to run some games that use 3d I either get a blank
screen or the graphics are very jumpy. Running  glxgears works fine but if try
to play a game called ballbuster I get a blank screen and sound. 

Version-Release number of selected component (if applicable):


How reproducible:
intermittent depending on game or 3d application 


Steps to Reproduce:
1.have Nvidia Gforce 2 200 MX installed 
2.Try to play ballbuster 
3.
  
Actual results:
Get blank screen

Expected results:
to be able to run games/ programs that use 3d reliably 

Additional info:
This worked in previous kernel version although the graphics would occasionally
hang.
Comment 1 Tim McConnell 2007-02-25 14:52:16 EST
Created attachment 148762 [details]
xorg.conf file
Comment 2 Tim McConnell 2007-02-25 14:53:25 EST
Created attachment 148763 [details]
previous settings
Comment 3 Tim McConnell 2007-02-25 14:53:53 EST
Created attachment 148764 [details]
for 3d
Comment 4 Tim McConnell 2007-02-25 14:55:12 EST
Created attachment 148765 [details]
dmesg file
Comment 5 Tim McConnell 2007-02-25 14:56:18 EST
Created attachment 148766 [details]
Xorg logs
Comment 6 Tim McConnell 2007-02-25 14:57:52 EST
Created attachment 148767 [details]
from switching to the nv to the nvidia drivers in system config display
Comment 7 Tim McConnell 2007-02-25 14:58:34 EST
Created attachment 148768 [details]
Xorg setup files
Comment 8 Tim McConnell 2007-02-25 15:08:14 EST
In proof reading I realized I didn't state the whole problem. 
If I launch system config display then go into the hardware tab  I am set to the
Nvidia drivers. When I am in that driver set I can run GLXGEARS and get the
blank screen from the game ballbuster. If I switch to the nv drivers restart the
gui and try to play ballbuster then I the display restarts the gui. 
In the Nvidia drivers I don't get the nvidia splash screen, but in nv settings I
do. If I run service nvidia-glx restart everything shows that it was ok. 
Please advise of any commands or additonal files (with locations) needed thanks. 
Comment 9 Tim McConnell 2007-02-26 00:22:55 EST
In comment #8 this is true in Gnome, in KDE everything works fine ;( 
Comment 10 Adam Jackson 2007-02-26 13:21:24 EST
The nv driver currently has no hardware acceleration for 3d.  s-c-d will allow
you to use the closed nvidia driver, but any problems that occur from doing so
are likely to be nvidia's fault.

In comment #8 it sounds like you are capable of making the software 3d code
crash when using the nv driver; is this the case?
Comment 11 Tim McConnell 2007-02-26 21:38:23 EST
(In reply to comment #10)
> The nv driver currently has no hardware acceleration for 3d.  s-c-d will allow
> you to use the closed nvidia driver, but any problems that occur from doing so
> are likely to be nvidia's fault.
> 
> In comment #8 it sounds like you are capable of making the software 3d code
> crash when using the nv driver; is this the case?

Yes I can in GNOME, I was hoping the xorg.log and the dmesg files would show that.  
Comment 12 Tim McConnell 2007-03-08 00:13:54 EST
Upgraded to kernel version  2.6.19-1.2911.fc6 #1 SMP Sat Feb 10 15:51:47 EST
2007 i686 athlon i386 GNU/Linux and it seems to have quit crashing. I also had
to run the command 'service nvidia-glx' restart to get the 3 d games to run (it
still hangs). It would appear as though the glx portion of the Nvidia 96xx is
not being recognized or started. I think that because I have to run 'service
nvidia-glx' each time I restart the computer. 
I have a question also; you state "The nv driver currently has no hardware
acceleration for 3d". I thought the driver was what provided the acceleration if
not what does? 
Comment 13 Adam Jackson 2007-03-08 10:48:30 EST
(In reply to comment #12)

> I have a question also; you state "The nv driver currently has no hardware
> acceleration for 3d". I thought the driver was what provided the acceleration if
> not what does? 

"The driver" does.  However, the nv driver in particular does not.  The nv
driver is the one that came with your system, and is the one that is supported.
 The nvidia driver is the closed source one you downloaded from nvidia, and is
not supported.
Comment 14 Tim McConnell 2007-03-08 12:32:43 EST
(In reply to comment #13)
> (In reply to comment #12)
 
> the nv driver in particular does not.  The nv
> driver is the one that came with your system, and is the one that is supported.
>  The nvidia driver is the closed source one you downloaded from nvidia, and is
> not supported.

Okay, when I filed this bug the display manager showed the "nv" as being the
closed source one and Nvidia as the open source one. In the new kernel it shows
them correctly and was defaulted to the nv driver. I will test again with the
supported one and advise if there are still problems. 
Comment 15 Tim McConnell 2007-03-08 15:30:12 EST
Created attachment 149621 [details]
Shows default settings
Comment 16 Tim McConnell 2007-03-08 15:31:24 EST
Created attachment 149622 [details]
Shows NVIDIA drivers selected
Comment 17 Tim McConnell 2007-03-23 23:08:12 EDT
I have upgraded to kernel 2.6.20-1.2925.fc6 with these "drivers":
kmod-nvidia-96xx-1.0.9631-4.2.6.20_1.2925.fc6
kmod-nvidia-96xx-kdump-1.0.9631-4.2.6.20_1.2925.fc6
nvidia-96xx-kmod-debuginfo-1.0.9631-4.2.6.20_1.2925.fc6
xorg-x11-drv-nvidia-96xx-devel-1.0.9631-5.lvn6
xorg-x11-drv-nvidia-96xx-1.0.9631-5.lvn6

and it seems to have straightened things out. Ballbuster still hangs
occasionally, if there is a way to get log files for that issue I would be more
than happy to get them for you, just let me know what and where they are. 
Comment 18 Adam Jackson 2007-05-26 14:37:31 EDT
Any issues you're experiencing with the nvidia drivers unfortunately have to be
addressed to nvidia.  We are unable to support closed source video drivers.

Note You need to log in before you can comment on or make changes to this bug.