Bug 230079 - PyQt is missing dependency to sip
PyQt is missing dependency to sip
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: PyQt (Show other bugs)
4.6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-26 10:37 EST by Tuomo Soini
Modified: 2009-01-22 10:52 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-22 10:52:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tuomo Soini 2007-02-26 10:37:42 EST
PyQt is missing dependency to sip at rhel-4u4 level

Shipped version is: PyQt-3.13-1

Seems to be fixed in later versions, from fedora extras pkg changelog:

* Fri Jan 21 2005 Than Ngo <than@redhat.com> 3.13-3
- Add missing sip dependency
Comment 5 Vivian Bian 2009-01-13 01:18:08 EST
The sip dependency could be seen in the new version of the PyQt-3.13-2.el4

Steps to check the result
1.# rpm -e sip
2.python -c 'import qt'

Effect:
In the Step1,the sip will not be erased .And you could see the sip is needed by (installed) PyQt4-3.13-2.el4.xxx
During Step2,you could import the qt successfully,without the module sip needed warning
Comment 8 errata-xmlrpc 2009-01-22 10:52:11 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0027.html

Note You need to log in before you can comment on or make changes to this bug.