Bug 230081 - libunwind missing on i386
Summary: libunwind missing on i386
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: libunwind   
(Show other bugs)
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Jan Kratochvil
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 173278
TreeView+ depends on / blocked
 
Reported: 2007-02-26 15:42 UTC by Andrew Cagney
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-05 20:35:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andrew Cagney 2007-02-26 15:42:05 UTC
The libunwind rpm is missing from i386.

Comment 2 Jan Kratochvil 2007-04-05 22:23:52 UTC
Testing release has been committed to RawHide.
No GDB or LIBUNWIND regressions were found against 0.98.5-3.
* Thu Apr  5 2007 Jan Kratochvil <jan.kratochvil@redhat.com> -
0.99-0.1.frysk20070405cvs
- Update to the upstream snapshot snap-070224.
- Use the Frysk's modified version, currently snapshot 20070405cvs.
- Extend the supported architectures from ia64 also to x86_64, i386 and ppc64.
- Spec file fixups.
- Split the package to its base and the `devel' part.
- Drop the statically built libraries.


Comment 3 Andrew Cagney 2007-04-09 18:53:05 UTC
Can the changes be pushed into the official repo?


Comment 5 Jan Kratochvil 2007-04-29 18:26:31 UTC
qa_ack: A testsuite is provided in the %check rpm section.  Regressions cannot
exist for i386 as this architecture was not present for libunwind in RHEL5.0.

ia64 regression analysis for upgrade of the package for the extended x86_64 +
i386 architecture set:
ia64: 0.98.5-3 -> 0.99-0.2.frysk20070405cvs
-------------------------------------------
regressions:
Gtest-resume-sig    + Ltest-resume-sig   : PASS -> FAIL
 - False regression, it was failing even in 0.98-5 but the test had false
   positive.  In fact the functionality does not work in both ia64 versions.

improvements:
Gia64-test-readonly + Lia64-test-readonly: FAIL -> PASS
ia64-test-setjmp                         : FAIL -> PASS

new tests:
run-ptrace-stepper: FAIL
run-ptrace-signull: XFAIL


Comment 6 RHEL Product and Program Management 2007-06-05 20:35:39 UTC
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Since this
bugzilla is in a component that is not approved for the current
release, it has been closed with resolution deferred.  You may
reopen this bugzilla for consideration in the next release.


Note You need to log in before you can comment on or make changes to this bug.