Bug 23014 - set -o vi doesn't work
set -o vi doesn't work
Status: CLOSED DUPLICATE of bug 21222
Product: Red Hat Linux
Classification: Retired
Component: bash (Show other bugs)
7.0
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-29 20:35 EST by Rene Uittenbogaard
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-30 09:23:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rene Uittenbogaard 2000-12-29 20:35:05 EST
when logged in with an account that has /bin/bash for a login shell, the
commands 'set -o vi' and 'set -o emacs' do not seem to work. 'set -o'
reports that the correct option has been set, but the shell doesn't respond
correctly. Using 'exec bash -o vi' solves the problem, after which 'set -o
vi' and 'set -o emacs' work correctly.
Comment 1 Bernhard Rosenkraenzer 2001-01-08 10:56:17 EST

*** This bug has been marked as a duplicate of 21222 ***
Comment 2 Ian Mortimer 2001-01-10 22:35:03 EST
I found a different variation of this bug.  If you put `set -o vi' in root's
.bashrc no editing
mode works when you login.  If you type `set  -o emacs' that works, but you
can't get
vi mode to work.   But if you remove the `set -o vi' from .bashrc then emacs
mode
works immediately and vi mode works after `set -o vi' from the command line.

Haven't tried this from a non-root account.

Note You need to log in before you can comment on or make changes to this bug.